Введение

 Top Next

RadioBOSS - автоматизация радиовещания, озвучка клубов, дискотек, казино, магазинов, кинотеатров. Легкий в освоении интерфейс программы и богатый функциональный набор позволят быстро добиться нужного результата в создании звукового оформления.

Для автоматизации вещания предалается масса различных функций: генератор плейлистов, музыкальная база, планировщик, рекламный планировщик, войсдропы, нарезки, вещание в интернет и прочее.

Если Вам нужно автоматизировать вещание радиостанции, озвучить торговый комплекс, клуб или казино, и при этом затратить как можно меньше усилий и денег, то мощная и простая в освоении программа RadioBOSS как раз для Вас!

Справка актуальна для версии RadioBOSS 5.7

Copyright 2003-2018 DJSoft.Net. All rights reserved.

RadioBOSS is the property of DJSoft.Net and is protected by international copyright law.


Регистрация

 Top Previous Next

Если вам понравилась данная программа, и вы хотите получить полную версию, вам нужно её оплатить.
Перед покупкой рекомендуем ознакомиться с последними обновлениями цен и реквизитов на сайте http://www.radioboss.ru/rus/buy.htm

Для регистрации программы:

1. Посетите сайт http://www.radioboss.ru и нажмите ссылку Купить

Выберите наиболее удобный способ оплаты. После оплаты в большинстве случаев ключ придет автоматически в течение нескольких минут.

2. После получения ключа, по запросу программы (или через меню Справка-Ввести регистрационный код...) введите ключ.

3. Окно для ввода ключа:

4. Введите ключ активации. Рекомендуется скопировать его с полученного вами сообщения.

5. Нажмите OK. Программа зарегистрирована, все ограничения сняты. Спасибо за использование RadioBOSS!

Если вы обновили программу (например, с версии Express до версии Standard), проделайте 5 шагов, указанных выше, для того, чтобы изменения вошли в силу.


Начало работы

Если не знаете с чего начать, прочтите этот раздел.

1. Запустите RadioBOSS.

2. Настройка мызыкальной базы - Music Library. База используется для быстрого поиска и автоматической генерации плейлистов.

Если вас эти функции не интересуют - можете пропустить шаг. Создание базы не является обязательным.

Для запуска Music Library, в меню выберите Инструменты - Музыкальная база.

Запустится программа:

Чтобы добавить музыку, нажмите на кнопку "Добавить папку" или выберите одну из команд меню Добавить

После добавления файлы появятся в таблице.

После того, как все файлы добавлены, сохраните и закройте базу.

3. Добавление музыки в плейлист. Добавление треков и прочих элементов в плейлист делается с помощью меню Плейлист.

Доступные команды:

RadioBOSS поддерживает работу с несколькими плейлистами. Нажмите на кнопку "+" чтобы добавить плейлисты если нужно. Также можно добавить Карт-машину или Web-браузер.

4. Назначение джинглов быстрого доступа. В меню выберите Джинглы->Назначить. Джинглы можно запустить нажатием кнопок 1-9 на клавиатуре.

5. Кроссфейды: В панели управления, выберите Кроссфейды, выставите желаемые значения.

6. Если у вас установлено несколько звуковых карт, или вам нужно определенным образом настроить вывод звука, откройте:

Настройки->Воспроизведение->Устройства.

В разделе Воспроизведение вы можете установить звуковые карты, которые настраиваются для воспроизведения.

Вы также можете настроить предпрослушку трека, которая позволит прослушать трек вне основного эфира, на отдельном звуковом устройстве.

Подробная информация о настройках звучания расположена в отдельном разделе: настройки воспроизведения.

7. Вещание в интернет. Если вы создаете интернет-радиостанцию, нужно сделать соответствующие настройки. RadioBOSS поддерживает ShoutCast, IceCast, Windows Media Server. Также есть встроенный сервер вещания. Это работает без дополнительных плагинов. Раздел Вещание в интернет описывает процесс настройки.

8. Настройте горячие клавиши. Большинство горячих клавиш по умолчанию включено, вы можете выключить или изменить их по своему усмотрению.

8. После того, как все настроено, запустите трек в плейлисте двойным кликом мыши!

Дополнительно:

Вещание в интернет

Создание музыкальной базы

Генерация плейлистов


Настройка прослушки (PFL)

Прослушка позволяет прослушать треки вне основного эфира, на отдельном звуковом устройстве.

Прослушка используется в плейлисте (нажатием правой кнопкой мыши на треке), музыкальной базе а также в Track Tool, редакторе кроссфейдов и записи голосовых треков.

Для настройки прослушки, в настройках программы в разделе Воспроизведение для карты Предпрослушка (PFL) выберите устройство, через которое вы будете прослушивать треки вне основного эфира.


Вещание в интернет

С помощью RadioBOSS можно легко организовать вещание в интернет. RadioBOSS может подключаться к серверам Shoutcast, Icecast или Windows Media Server. Все, что играет в программе будет отправлено на сервер. Возможно одновременное вещание на любое количество серверов.

Для настройки вещания выполните следующие шаги:

1. В меню выберите Настройки -> Настройки...

2. Выберите раздел Вещание

Укажите название станции, жанр и прочие параметры. Это общие параметры - для каждого сервера эти параметры, при необходимости, их можно переопределить.

3. Нажмите кнопку "+" для добавления сервера вещания.

4. Появится окно настроек:

Рекомендуем использовать Мастер настройки для облегчения процесса настройки.

Адрес сервера и пароль - эти параметры передаются вам хостинг-сервисом (или введите свои параметры если используется собственный сервер).

Если у вас нет радио хостинга, то можете приобрести его на сайте: https://www.radioboss.fm/ru/

Частота, Формат, Битрейт и Каналы - устанавливают формат вещания.

На вкладке Информация можно изменить данные станции конкретно для этого подключения.

На вкладке Метаданные можно выбрать параметры отправления названия трека на сервер.

Вкладка Статистика позволяет изменить способ получения статистики (данных о количестве слушателей) для сервера, подробнее о настройке.

После того, как все настройки введены, нажмите ОК. Подключение будет добавлено в список.

5. В разделе Вещание установите "галочки" напротив серверов, которые вы хотите использовать. Также установите опцию "Включить вещание", расположенную вверху окна.

6. Нажмите OK.

Если все настроено верно, в отчете (левый нижний угол) появится сообщение Connected to server! (output N).

Если вещание идет на порт, отличающийся от порта прослушивания, то для получения информации о количестве слушателей нужно настроить Statistic Relays.

В случае неправильных настроек, в окне отчета будет сообщение об ошибке, выделенное красным. В сообщении будет указан сервер, для которого подключение не удалось (например, "output 1" - первый в списке).

Откройте окно настроек и убедитесь, что все параметры введены верно.

Статистику по количеству слушателей можно смотреть в окне Статистики. Чтобы открыть окно нажмите Вид -> Статистика вещания или кнопку Статистика на панели инструментов.

Наиболее часто встречающиеся сообщения об ошибках:

Cannot start broadcasting (output N): Error 2100

Неправильные имя пользователя или пароль - проверьте эти данные.

Cannot start broadcasting (output N): Error 2

Не удалось подключиться к серверу - проверьте, правильно ли введен адрес, порт. Также проверьте, что антивирус или файрвол не блокируют соединение.

После того, как всё правильно настроено, RadioBOSS будет передавать все, что играет в программе на сервер вещания.

Cannot start broadcasting (output N): Error -1

Обычно эта ошибка появляется если кто-то другой уже подключен к серверу

(*) Настройки Источник позволяет выбрать источник сигнала, который будет передаваться на сервера

Audio mix | По умолчанию. Все, что играет в программе, будет передаваться на сервера вещания.
Input 1 Input 2 | Один из линейных входов можно выступать источником. Настройки линейных входов.

Дополнительно:

Создание музыкальной базы

Генерация плейлиста


Получение статистики

Функция позволяет настроить способ получения статистики (количества подключенных слушателей).

По умолчанию, статистика берется с сервера, на который идет вещание. Это не требует дополнительной настройки.

Можно также получать статистику с другого сервера. Это может быть полезно в случае, когда вещание идет на один сервер, а слушатели подключаются к другому: такая ситуация типична для распределенных серверов, или систем где есть автодиджей или вещают несколько диджеев из разных мест.

Подключение может быть использовано только для получения статистики, без вещания на сервер. В этом случае, в разделе Подключение оставьте поле Сервер пустым.

Для получения статистики с другого сервера в меню нажмите Настройки -> Настройки -> Выберите раздел Вещание -> Откройте нужное подключение двойным кликом мыши по нему и выберите вкладку Статистика.

Выберите опцию "Указать сервер для получения статистики".

Выберите тип сервера - Shoutcast или Icecast - это тип сервера, с которого будет браться статистика.

В поле Сервер вводится адрес сервера (без http://), например: example.com:9000

Пароль - пароль для сервера, это либо пароль администратора, либо пароль вещания, зависит от сервера.

Маунт/Stream ID - название маунта (обязательно для Icecast) или ID потока для Shoutcast (если не задано ID, будет получено общее количество слушателей на сервере).

Если все настроено правильно, в окне статистики можно будет видеть количество слушателей. Иначе, в таблице вместо количества слушателей будет сообщение об ошибке.


Планировщик

Планировщик позволяет автоматически запускать файлы, плейлисты и интернет-потоки (URL) по расписанию. Это может быть использовано, например, для вывода рекламных сообщений, ретрансляции, выпуска часовых отбивок.

Также в планировщике могут быть использованы команды (например, взять случайный плейлист из папки, изменить громкость, создать плейлист и прочее). Большинство команд может быть назначено с помощью Мастера.

Для создания заданий:

1. В Панели управления, выберите вкладку Планировщик.

Будет открыт список имеющихся заданий и функции управления:

2. Нажмите кнопку Добавить...

Откроется окно настроек задания:

3. Нажмите кнопку открыть для выбора плейлиста или трека, который вы хотите запускать по расписанию. Или нажмите кнопку мастера для выбора действия:

4. Установите время и дату запуска задания.

Дополнительно можно установить повторение задания, выбрать дни недели, выбрать дату окончания задания. В правой части окна расположены дополнительные опции запуска.

5. Нажмите OK для создания задания.

Задание появится в списке заданий.

Если активирована опция Manual, то задания будут во включенном режиме, но запускаться будут только вручную (кнопкой Запустить). Команды makelibrary; createbackup; download будут запускаться в любом случае.

См. также:

Планировщик

Настройки задания

Задания


Задания

Имя файла трека/плейлиста или команда - плейлист, трек, URL или команда для запуска. Мастер [image] может быть использован для облегчения настройки.

Нажатием на кнопку [image] можно назначить несколько действий на задание.

В имени файла также можно использовать шаблоны, которые будут заменены программой на соответствующие значения:

?yyyy | текущий год (4 цифры) | ?dd | день (2 цифры)
?yy | текущий год (2 цифры) | ?hh | час (2 цифры)
?mm | месяц (2 цифры) | ?nn | минута (2 цифры)
?wd or ?dw | текущий день недели (2 цифры): 01 до 07 | ?noeval | если указано, шаблон вычисляется при воспроизведении; если не указано - вычисляется при запуске задания

Вы можете использовать эти опции для сокращения количества заданий при запуске однотипных плейлистов или треков.

Пример: задано имя файла “C:\Playlists\?yyyy-?mm-?dd.m3u” и текущее число 2-е февраля 2012. Используя данный параметр, будет открыть этот список с именем “C:\Playlists\2012-02-02.m3u” , а на следующий день он будет открыт с именем “C:\Playlists\2012-02-03.m3u” и т.д.

Дата и время могут быть скорректированы с помощью параметров: ?(+|-)N(y|m|d|h|n)

Модификатор добавляется в конце команды.

Например: Задана команда C:\Playlists\?yyyy-?mm-?dd.m3u?+2d (модификатор отмечен красным цветом, который обозначает, что к заданной дате добавлено 2 дня), заданная дата 2 февраля 2016. Используя данный параметр, будет открыт плейлист с именем C:\Playlists\2012-02-04.m3u; а на следующий день он будет открыт плейлист с именем C:\Playlists\2012-02-05.m3u и т.д.

Модификаторы могут изменяться: y - год, m - месяц, d - день, h - час, n - минута.

Имя задания - можно назначить любое имя для задания, оно будет отображено в списке.

Группа: группа, к которой принадлежит задание. Это поле можно оставить пустым - в этом случае событие не будет принадлежать к группе. Вы можете ввести имя группы (или нажмите стрелку вниз, если вы хотите выбрать из существующих групп). Группы используются для более удобной организации списка заданий. Можно изменить цвет группы, добавив тег [#color] после ее названия. Например: Реклама[#red] - в списке заданий будет отображено красным. Значением color может быть: red, green, blue, gray, yellow и прочие названия цветов, также можно задать код цвета в шестнадцатеричном RGB формате [#AABBCC].

Цвета: цвет задания в списке. Щелкните на панель для выбора цвета.

Кнопка Удалить удаляет задание из списка.

Кнопка Копировать сохраняет задание как копию (вместо редактирования).

Кнопка По умолчанию создает стандартные настройки: эти настройки будут использоваться при добавлении новых заданий.

Время и день

Здесь устанавливается время и день запуска.

Дата и Время - установить день и время запуска

Учитывать дату - если установлен, то трек будет запущен только в тот день, который установлен в поле "Дата", иначе будет запускаться только в указанные дни недели.

Дни недели - отметьте дни недели, когда трек должен запускаться. Позволяет задавать расписание сразу на всю неделю.

Рядом с полем для ввода даты расположена кнопка, при нажатии на которую можно выбрать опцию "Каждый год", тогда задание будет запускаться в указанный день каждый год.

Weeks: задает номер дня недели в месяце, в который должно выходить задание. Например, если включены "2nd" и "Last", а в Дни недели выбрано воскресенье, то задание выйдет во второе и последнее воскресенье месяца.

Часы - вместо указания времени, можно выбрать часы и минуты, по которым будет запускаться задание. Для настройки нажмите кнопку [...].

Если установлена Дата и опция Дни недели выключена, задание будет выполнено только в указанную дату. Если установлены обе опции Дата и Дни недели, в этом случае дата устанавливает дату начала выхода задания, после которой оно будет выходить в выбранные Дни недели, даже после указанной даты.

Задания могут быть также запущены по DTMF метке.

Повторы

Повтоярть каждые [X] минут не более [Y] раз - задание будет запущено Y раз через равные промежутки времени Х. Например: "Повторять каждые 15 минут не более 10 раз", в этом случае задание будет запущено в установленное время (например, 01:05), затем еще 9 раз через каждые следующие 15 минут (т.е. в 01:20, 01:35, 01:50, ...). Предупреждающий значок появится, если повторения превысят 24 часа (которые впоследствии могут привести к ненужным событиям запуска).

Окончание

Позволяет выключить или удалить задание в указанное время.

Ожидание

Максимальное время ожидания в очереди - укажите время ожидания в минутах. Если воспроизведение не начинается в течение указанного времени, будет выполнено действие:

Удалить - треки будут удалены из очереди.

Запустить - треки будут запущены.

Данная опция также может использоваться вместе с опцией Запускать поверх эфира, в этом случае, запуск поверх эфира будет отложен до конца текущего трека. Если до конца текущего трека осталось больше времени, чем установленное время ожидания, и действие по окончанию ожидания - Запустить, то ожидание выполнено не будет, а событие будет запущено сразу.

Опции

См. Опции задания.

См. также:

Команды

Опции задания


Настройки задания

Опции

Включить задание | Можно использовать эту опцию для временного выключения задания.
Не запускать задание если плейлист остановлен | Если плейлист не играет, задание не будет запущено.
Отправлять название задания на сервер вместо названия треков | На сервере вещания будет использоваться название задания, а не названия треков.
Вставить добивку перед запуском задания | Перед запуском задания будет вставлена добивка. Более подробно о добивках.
Запустить не дожидаясь окончания играющего трека | Если включен, то трек/плейлист будет запущен точно в то время, которое указано в поле "Время", иначе он встанет в очередь и будет запущен после того, как отыграет текущий трек.
Если в плейлисте есть треки из расписания, поставить в очередь | Если в плейлисте уже имеется загруженный по расписанию плейлист, новый блок будет помещен после него.
Удалять предыдущее расписание из плейлиста | При запуске задания удалятся все треки предыдущих заданий, которые были в плейлисте (в примере выше, будут удалены треки номер с 6 по 14).
Очистить плейлист | Содержимое текущего плейлиста будет очищено.
Вставить плейлист в случайном порядке | Если в поле имя файла стоит имя плейлиста, то перед вставкой этот плейлист будет перемешан.
Вставить как обычные треки плейлиста | Обычно треки. запущенные по расписанию, автоматически удаляются из плейлиста. Включение опции позволяет избежать этого. Также, есть некоторые "побочные эффекты", которые могут быть полезны в некоторых ситуациях: ·Треки не будут помечены значком "часов", вместо этого треки будут с обычными значками ·Некоторые опции не будут воспринимать эти треки как треки расписания: * Если в плейлисте есть треки из расписания, поставить в очередь * Удалять предыдущее расписание из плейлиста
Играть поверх эфира | Если установлен, то трек будет запущен поверх основного эфира. При этом имеется возможность понизить громкость эфира регулятором "уровень музыки", который расположен ниже. Например, трек “Don't Stop” (см. скриншот ниже) играет поверх основного эфира.
Пока играет задание поставить плейлист на паузу | Поставить плейлист на паузу, запустить задание, снять с паузы.

Пример: запущено задание с опцией "Играть поверх эфира".


Sweepers

Добивки используются для предотвращения прерывания трека перед запуском задания. Допустим, воспроизведение песни только началось, а через 20 секунд есть задание, запуск которого оборвет песню. Чтобы избежать такой ситуации, RadioBOSS может вставить добивку, в данном случае песня не запустится, вместо этого 20 секунд будет играть добивка, после чего будет запущено задание.

Чтобы вставить добивку: в окне настройки задания нажмите кнопку "Добивки...", чтобы выбрать папку с добивками. Чем больше добивок с разной длительностью находится в папке, тем лучше.

Чтобы задать правила неповторения для добивок, в окне добивок нажмите кнопку "Правила неповторения..." или в главном меню нажмите Плейлист -> Дополнительно -> Добивки: правила неповторения... Настройки правил неповторения общие для всех добивок.

Качество выборки добивки может контролироваться в настройках в разделе Планировщик.


Команды

Список доступных команд планировщика. Все команды, за исключением некоторых, могут быть вызваны через Карт-машину или использованы непосредственно в плейлисте (меню Плейлист -> Добавить команду...).

Информация: в окне задания есть кнопка Мастера, с помощью которой большинство команд не нужно вводить вручную.

play X

Запустить трек номер х в плейлисте

stop

Остановить воспроизведение

next

Перейти к следующему треку

prev

Перейти к предыдущему треку

run filename parameters

Запустить любую программу или .bat файл

Пример:

run C:\dosomething.bat

run C:\AnyProgram.exe -switch1 -switch2

generate preset_name

generate [pro] preset_name

Сгенерировать плейлист используя пресет preset_name, сохраненный в генераторе. Например, в генераторе создан пресет под названием "ROCK 2 Hours" (без кавычек), чтобы по расписанию создать плейлист по этому шаблону, используется команда generate Rock 2 hours

setvol x

Установить громкость эфира в x (от 0 до 100). Например, setvol 70 . Также, можно указать период, в течение которого будет меняться громкость (в миллисекундах, 1000мс = 1сек), например, setvol 70 500 - изменит уровень громкости до 70 в течение 0.5 секунды

load filename

Загрузка файла filename. Это может быть профиль (.prf), плейлист (.m3u) или список заданий планировщика (.sdl). Если не указано полное имя файла, то профиль ищется в папке \Profile, плейлист в папке \Playlist, файл расписания в папке \Presets\Schedule. Плейлисты загружаются в список Main

load text ZN:Name; filename|text

Загрузить текст во вкладку с блокнотом.

ZN: - номер зоны (Z2, Z3)

Name - название вкладки

filename|text - путь к файлу, из которого нужно загрузить текст или сам текст.

Пример: загрузить текст "this is test" во вкладке NOTE0 во 2 зоне

load text Z2:NOTE0; this is test

getrandomplaylist folder_name

Загрузить случайный плейлист из папки folder_name.

Пример:

getrandomplaylist d:\music\playlists.

clearplaylist

Очистить плейлист Main

reboot

Перезагрузить компьютер

poweroff

Выключить компьютер

connect

disconnect

connect - подключиться к серверу вещания, если не указан параметр, то происходит подключение ко всем серверам, указанным в настройках. Также в качестве параметра можно указать число от 1 до 5 чтобы подключиться к определенному серверу

disconnect - параметры аналогично команде connect, только команда выполняет отключение от сервера

scheduler on

scheduler off

Команды для временного включения или отключения расписания

команда выключения расписания (scheduler off) переводит планировщик в режим ожидания - в этом режиме никакие задания расписания не работают кроме задания с командой включения расписания: scheduler on

команда scheduler on также отключает опцию Manual

streamarchive on|off

streamarchive FILENAME

Включить или выключить функцию Запись потока

(меню: Инструменты->Запись потока)

streamarchive on - включить запись потока

Начать запись и сохранить в указанное имя файла:

streamarchive D:\myshow.mp3

makelibrary LibraryFile Dir1 Dir2 ...

Создать или обновить файл музыкальной базы. Параметры команды разделяются с помощью символа "|" или пробела.

Первый параметр указывает путь к файлу музыкальной базы, которую нужно создать. Второй и последующие - папки, которые должны быть просканированы (включая подпапки). Также, вместо папки можно указать путь к плейлисту или музыкальной базе.

Пример 1: создать файл музыкальной базы my.xml в папке по умолчанию (меняется в настройках) и добавляет в него треки из папки C:\Music

makelibrary my.xml C:\Music

Пример 2: аналогичен Примеру 1, но добавляет треки из двух папок: C:\Music и D:\MoreMusic:

makelibrary my.xml C:\Music D:\MoreMusic

Пример 3: используется полный путь к .xml файлу базы

makelibrary "C:\path to save\my.xml" C:\Music

Пример 4: Использование плейлиста в качестве источника треков

makelibrary my.xml C:\playlist.m3u8

Внимание! Если имя файла или плейлиста содержит пробелы, то имя нужно заключить в кавычки.

Пример:

makelibrary "Muzica Italiana.xml" "D:\Muzic\Music Italia"

adsupdate

Обновить задания и плейлисты из рекламного планировщика. Выполнение этой команды аналогично нажатию кнопки "Создать задания и плейлисты" в рекламном планировщике.

createbackup FileName

Создать резервную копию насторек и заданий планировщика.

Пример:

createbackup C:\RB_backup.7z

createbackup C:\RB_Backup_?yyyy-?mm-?dd.7z

Во втором примере используется макрозамена.

download URL FILENAME

Скачать файл с интернета и сохранить как FILENAME. Если не указывать имя файла, то программа просто обратится к заданному URL ничего не сохраняя - это можно использовать для отправки уведомлений.

Пример:

download http://www.example.com/file1.exe D:\savedfile.ext

Пример: скачать подкаст (будет скачан самый новый файл из списка)

download podcast http://www.example.com/podcast.xml D:\podcast.mp3

Пример: скачать файл с сказанием имени пользователя и пароля

download http://USERNAME:PASSWORD@www.example.com/file1.exe D:\savedfile.ext

folder_path

folder_path/

Добавить треки из папки в плейлист. Если в конце пути добавить слеш "/", то файлы будут добавлены в случайном порядке, иначе - в алфавитном порядке.

Пример:

D:\Music или D:\Music\ - добавить треки из папки D:\Music folder в алфавитном порядке

D:\Music/ - добавить треки из папки D:\Music в случайном порядке

download [podcast] URL FILENAME

Скачать файл с интернета и сохранить как FILENAME.

Чтобы запустить определенный URL без сохранения каких-либо файлов, опустите параметр FILENAME (это можно использовать для отправки уведомлений).

Если указано ключевое слово podcast, URL должен указывать адрес подкаста, RadioBOSS выберет самый новый подкаст и скачает его.

Пример:

download http://www.example.com/file1.exe D:\savedfile.ext

Пример: скачать подкаст (будет скачиваться последняя версия)

download podcast http://www.example.com/podcast.xml D:\podcast.mp3

Пример: скачать файл, содержащий имя пользователя и пароль для авторизации

download http://USERNAME:PASSWORD@www.example.com/file1.exe D:\savedfile.ext

Пример: вызвать скрипт по указанному адресу, но не сохранять

download http://www.example.com/thescript.php

fadeout time_ms

Плавно выключить плейлист (сбавление громкости до нуля за время time_ms с последующей остановкой). Например, fadeout 500

set com(1-9) (dtr|txd)

clr com(1-9) (dtr|txd)

Установить/сбросить значение на выходе com-порта; выход может быть одним из dtr (пин 4) или txd (пин 3).

Например:

set com1 dtr - установить высокий уровень на dtr com1.

clr com2 txd - сбросить (установить низкий уровень) на выходе txd порта com2. Низкий уровень на com-портах соответствует -12В, высокий +12В

send COMX text

Отправить строку text на COM-порт COMX.

COMX - имя ком-порта, например, COM1

text - текст, который нужно отправить в порт

set func_name [on|off]

clr func_name

Включить или выключить функцию func_name.

Пример (используя set и clr): set func_name - включить функцию clr func_name - выключить функцию

Пример (используя модификатор on/off): set func_name on - включить функцию set func_name off - выключить функцию

Возможные значения FUNC:

shuffle - режим shuffle (случайное воспроизведение)

repeat_track - повтор трека

repeat_list - повтор

break - остановка после текущего трека

autoamp - автоматический контроль громкости (AutoAmp)

http_request - HTTP запрос

manual - ручной режим (Manual) в планировщике

autointro - включить или выключить Auto Intro (Авто интро)

Также команда set может использоваться, чтобы установить значение переменной %showname:

set %showname=TEXT

Переменную %showname можно использовать в HTTP запросе.

setencodersource SRC

Изменить источник звука для вещания.

Возможные значения SRC:

0 - Audio mix

1 - Input 1

2 - Input 2

Для более подробной информации: Вещание интернет радио

Пример:

setencodersource 0

silencedetector on

silencedetector off

Включить и выключить детектор тишины

silencedetector on - включить

silencedetector off - выключить

Команда может также использоваться для изменения параметров:

silencedetector timeout N - изменить время срабатывания (в секундах)

silencedetector playlist FILENAME - изменить имя файла плейлиста, запускаемого при обнаружении тишины

getfile C:\path_to_folder [/random|/newest|/oldest] /delete

Команда добавляет один файл (трек или плейлист) из папки в плейлист. Команда может выбрать самый старый или самый новый (по дате добавления) файл или же случайный файл. В выборке могут быть как музыкальные треки, так и файлы плейлистов.

Синтаксис:

getfile C:\path_to_folder [/random|/newest|/oldest] [/delete]

Если путь к папке содержит пробелы, его нужно заключить в кавычки.

/random - выбрать случайный трек

/newest - выбрать самый новый трек из папки

/oldest - выбрать самый старый трек из папки

/delete - удалить файл после воспроизведения

Например: играть один файл из папки обьявлений и удалить его с диска после воспроизведения:

getfile C:\announcements /newest /delete

Параметр удаления (/delete) можно опустить, если вы не хотите, чтобы файл удалялся после воспроизведения.

playrequestedsong

playrequestedsong N

Запустить один из запрошенных пользователями треков.

Вы также можете указать минимальный интервал времени, который должен пройти между запросом и постановкой песни в эфир. Например, playrequestedsong 30 - задержать воспроизведение запрошенного трека на 30 минут. Рекомендуется поставить задание с этой командой на повтор, например, каждые 10 минут в течение периода, когда вы хотите принимать заказы песен.

См. также команды API: songrequest, songrequestclear

weather city, country

Обновить данные о погоде, см. Автоматическое объявление погоды

Например: weather New York, US

setdtmfsource 1|2|URL

Установить источник для детектора DTMF.

1 - Вход 1

2 - Вход 2

URL - указать URL интернет потока

Пример: setdtmfsource http://example.com:8000

stopoverlays

Остановить все играющие задания "поверх эфира"

enablegroup GROUP

disablegroup GROUP

Включить (enablegroup) или выключить (disablegroup) группу заданий

GROUP - название группы, которую нужно включить/выключить

enablevo

disablevo

Включить (enablevo) или выключить (disablevo) Войсдропы.

autointro [disable|enable] rule1, rule2, ...

Включить или выключить отдельные правила Авто интро. Названия правил не чувствительны к регистру.

Пример: выключить правила Утро и День

autointro disable Утро, День

Пример: включить правило Исполнитель

autointro enable Исполнитель


Запуск заданий по метке DTMF

Программа RadioBOSS поддерживает запуск запланированных заданий по сигналу DTMF. Этот способ можно использовать, например, для ретрансляции передач другой станции со вставкой региональных рекламных блоков. При этом для синхронизации используется сигнал DTMF.

Настройка DTMF

Сначала укажите источник DTMF. Для этого в окне «Настройки» выберите DTMF.

Выберите вход (Вход 1/Вход 2) или URL. Если выбрали вариант «URL», то введите URL сетевого потока. Программа подключится к нему для поиска сигнала DTMF в потоке.

Детектор DTMF включается и отключается автоматически.

Настройка заданий

В окне свойств события включите опцию DTMF и введите DTMF-последовательность (например, 764C). Когда данная последовательность обнаружится, задание будет запущено.

RadioBOSS начнет ловить метки DTMF за 5 минут до начала задания и закончит через 5 минут после начала задания. По умолчанию используется интервал длительностью 5 минут, но это значение можно изменить на вкладке DTMF в настройках. Например, если задание должно начаться в 01:00:00, то детектор DTMF будет работать с 00:55:00 до 01:05:00. Если сигнал DTMF не будет обнаружен в этот промежуток времени, то задание будет запущено в конце отслеживания DTMF - в данном примере в 01:05:00. Во избежание этого, включите опцию Только DTMF. В этом случае задания будут запускаться только по сигналу DTMF. Если метки не было, то задание запущено по времени не будет.

Для завершения задания по метке DTMF включите опцию Вылет DTMF и введите последовательность.

Несколько DTMF меток могут быть указаны для начала и окончания DTMF, например, “764C, 1D56” - задание может быть начато одним из двух тонов “764C” или “1D56”.


Генератор плейлистов

Playlist Generator Pro

Программа Playlist Generator Pro позволяет создавать плейлисты с заданной ротацией. Ротация определяет, какие треки, из какого источника и сколько треков будут добавлены в плейлист. В программе есть опция для предотвращения повторного добавления одних и тех же треков, исполнителей, альбомов, а также фильтры и другие правила. Используя генератор плейлистов, можно автоматически создавать плейлисты по заданному шаблону. Плейлисты можно создавать либо вручную, либо по расписанию, используя команду generate.

Чтобы запустить Playlist Generator Pro, выберите в меню Плейлист -> Генератор плейлистов.

Общие сведения и пример использования

Программа Playlist Generator Pro создает плейлист с заданной ротацией, состоящей из определенных категорий.

Категория состоит из треков, которые будут использованы в плейлисте.

Пример:

Создадим плейлист продолжительностью 8 часов со следующим составом:

§Top100

§Station ID

§Music

§Station ID

§Music

§Station ID

Как нетрудно заметить, у нас всего 3 типа треков. Поэтому создадим 3 категории треков: Station ID, Top100, и Music.

Для создания категории щелкните по кнопке «+» под списком категорий. Появится окно с настройками категории:

• На вкладке Общие введите название категории (она будет показана в списке под этим названием, например: «Music»), длительность (в примере выше это 1 трек).

• На вкладке Треки выберите источник треков для данной категории. Это может быть плейлист, папка, музыкальная база или отдельный трек. Из указанного источника будет взято нужное количество треков.

• Для категории Station ID рекомендуется включить опцию «Игнорировать опции "не повторять исполнителя/трек"» на вкладке Не повторять. Данная опция рекомендуется для джинглов, вставок с информацией о станции и немузыкальных треков.

• Щелкните по кнопке OK.

• Аналогично создайте остальные категории.

После создания всех категорий необходимо задать состав плейлиста. Выберите нужную категорию в списке и щелкните по кнопке «стрелка вправо», чтобы добавить эту категорию в состав плейлиста. Для изменения порядка категорий в списке воспользуйтесь кнопками «стрелка вверх» и «стрелка вниз» (справа от списка), а для удаления категории из списка — кнопкой «–» (в левом нижнем углу окна). Категории также можно перетаскивать мышью.

В приведенном выше примере будет создан следующий плейлист:

* Top100

* Station ID

* Music

* Station ID

* Music

* Station ID

Это означает, что в состав плейлиста войдут лишь эти четыре элемента.

В примере нам нужно было создать плейлист продолжительностью 8 часов, поэтому мы воспользовались опцией «Общая длительность плейлиста», выставив 8 часов 0 минут. Если не включить эту опцию, то генератор плейлиста лишь однократно пройдет через состав плейлиста (ротацию), и на этом создание плейлиста будет завершено.

При включенной опции «Общая длительность плейлиста» (как в нашем примере) генератор будет вновь и вновь проходить через состав плейлиста до достижения требуемой продолжительности.

Результат будет примерно такой:

Est. duration - показывает время одного цикла ротации.

Total playlist length - показывает общее заданное время проигрывания плейлиста.

Чтобы повысить качество плейлиста, на вкладке Настройки можно задать разные правила запрета повтора.

Опции создания плейлиста можно сохранить для последующего использования (кнопка «Сохранить пресет» в верхней части окна). Чтобы переименовать пресет, нажмите правой кнопкой мыши на название пресета. Сохраненный пресет можно использовать, например, для запланированного автоматического создания плейлистов.

Для создания плейлиста щелкните по кнопке «Генерировать». Откроется вкладка «Отчет», где можно просмотреть ход создания плейлиста, ошибки и результирующую длительность.

Плейлист можно сразу загрузить в программу RadioBOSS, щелкнув по кнопке «Отправить в плеер».

Для сохранения созданного плейлиста в файл щелкните по кнопке «Сохранить плейлист».

Вы можете создавать несколько плейлистов сразу. Для этого нажмите на стрелку рядом с кнопкой Генерировать - Создать несколько плейлистов... Подробнее о создании нескольких плейлистов.

См. также

Параметры командной строки

Настройки

Категории


Категории

Для создания категории щелкните по кнопке «+» под списком категорий:

Появится окно с настройками категории.

Настройки категорий:

Общие

Треки

Фильтр

Приоритет

Не повторять


Общие

Название - название категории, которая будет показана в списке под этим названием - например, "Music".

Длительность - количество треков или минут, которое будет браться из категории при каждом цикле ротации.

Использовать все треки из источника - каждый раз будут использованы все треки источника.

Использовать только один раз - данная категория будет использована только один раз (при первом цикле ротации).

Концовка: добавить только в конец плейлиста - добавить созданную категорию только в самый конец плейлиста.


Треки

На вкладке Треки выберите источник треков для данной категории. Это может быть плейлист, папка, музыкальная база или отдельный трек. Можно использовать несколько источников.

В имени файлов можно использовать специальные теги, которые будут заменены программой на соответствующие значения:

?yyyy | текущий год (4 цифры)
?mm | месяц (2 цифры)
?dd | день (2 цифры)
?hh | час (2 цифры)
?nn | минута (2 цифры)

Выбор треков можно задать случайный или по порядку. При выборе по порядку треки в источнике сортируются по алфавиту.

Начальная позиция - устанавливает начальную позицию треков в источнике, с этого трека будет начата выборка при использовании опции "По порядку". Обычно эта функция используется для выпуска каких-либо материалов (например, лекций), состоящих из нескольких частей. Настройка "Увеличивать позицию при каждой генерации" позволяет увеличивать начальную позицию для следующего раза (чтобы при следующем создании плейлиста бралась следующая часть).


Фильтр

На вкладке Фильтры можно задать дополнительные фильтры для треков, такие как год, время, рейтинг, длительность. Значения для фильтров работают включительно.

Фильтр по году

Для фильтра по году можно использовать значения now и prev - текущий и предыдущий год соответственно.

Фильтр по комментарию

Задается одно или несколько слов для фильтра. При наличии любого из этих слов в комментарии трека, трек пройдет фильтр. Также можно задать слова, наличие которых обязательно, используя ключевое слово REQUIRE. Используя ключевое слово NOT, можно исключать треки. Ключевые слова в тегах трека нужно приписывать через запятую (,) или точку с запятой (;): slow, moody, 80s.

Пример фильтра: bass, synth, REQUIRE 90s, NOT slow - выбрать треки, которые содержат в комментарии bass или synth, обязательно содержат 90s и не содержат slow.

Фильтр по жанру

Задается один или несколько жанров для выбора треков. Чтобы задать несколько жанров, нужно перечислить их через запятую: pop, rock (в этом случае в категории будут треки Pop или Rock). Треки, жанр которых не указан, исключаются.

Фильтр по полу

Фильтр треков по полю "Пол". Чтобы задать несколько вариантов, нужно перечислить их через запятую.

Фильтр по языку

Задается один или несколько языков для выбора треков. Чтобы задать несколько языков, нужно перечислить их через запятую.


Приоритет

Вкладка Приоритеты позволяет настроить расширенные правила выборки треков. Приоритет - это вероятность попадания трека в плейлист. Выборка треков по приоритету зависит от количества воспроизведений, рейтинга и даты последнего воспроизведения. Например, трек, который не играл давно, или трек, который имеет высокий рейтинг, может иметь больший шанс попасть в плейлист. Для непопулярных треков шанс можно понизить.

Приоритет треков вычисляется автоматически, основываясь на заданных правилах. Каждый трек имеет базовый приоритет 50. Приоритет 50 означает "обычный" шанс трека попасть в плейлист. Значения ниже 50 уменьшают шанс, значения выше - увеличивают. Значение приоритета варьируется от 0 до 100. 0 означает очень маленький шанс трека быть в плейлисте, значение 100 увеличивает шанс в 3-4 раза в сравнении с базовым приоритетом в 50. Приоритет трека ниже 0 исключает трек из воспроизведения.

Правила приоритета меняют приоритет трека при заданном условии: кол-во запусков, год, последний запуск или жанр. К примеру, для трека, который не проигрывался в течение продолжительного времени, вы можете увеличить шанс на воспроизведение. Этот шанс может быть занижен для непопулярных треков.

Для правила "кол-во запусков" можно использовать значения MIN, MAX, AVG (минимум, максимум, среднее). Например, вы хотите увеличить приоритет для воспроизведения трека при условии, что количество запусков меньше AVG (среднего).

Для правила "год" вы можете использовать значения NOW или CURRENT для указания текущего года, значения PREV или PREVIOUS для указания предыдущего года. Можно использовать простые расчеты, например: CURRENT-1 - предыдущий год.


Не повторять

На вкладке Не повторять можно переопределить глобальные настройки неповторения исполнителя, трека, альбома, названия трека, а также задать дополнительные правила неповторения (год, жанр, язык, пол).

Для джинглов, вставок с информацией о станции и немузыкальных треков рекомендуется включить опцию «Игнорировать опции "не повторять исполнителя/трек"».


Настройки

Для повышения качества плейлиста, на вкладке «Настройки» можно задать разные правила запрета повтора:

Не повторять исполнителя в течение... - задается период неповторения исполнителя в минутах.

Связанные исполнители - позволяет запретить повтор схожих исполнителей. Эта опция используется и в таких ситуациях, когда исполнитель известен под несколькими именами или один и тот же музыкант исполняет песни сольно и в группе. Для настройки данной функции в окне "Связанные исполнители" нажмите кнопку "+", добавьте исполнителя и нажмите "ОК". Далее откройте (двойным кликом мыши или правой кнопкой мыши нажмите "Правка") только что созданного исполнителя и в новом окне введите схожих исполнителей по одному на строке.

Несколько исполнителей - задает правила неповторения для нескольких исполнителей, указанных через разделитель (например, если исполнитель трека указан как Metallica feat Alphaville, то не будут повторяться отдельные исполнители: Metallica и Alphaville).

Считать одинаковыми исполнителей, совпадающих на ... % - позволит вам регулировать отбор схожести исполнителей. Вы можете протестировать связанность исполнителей, нажав кнопку "Тест", в появившемся окне введите исполнителей и узнайте на сколько процентов они схожи:

Не повторять трек в течение... - задается период неповторения трека в минутах.

Не повторять альбом... - задается период неповторения альбома в минутах.

Сравнивать альбомы только одного испольнителя - правило "не повторять альбом" можно задать только для одного исполнителя.

Не повторять название трека - задается период неповторения названия трека в минутах (например, в таких случаях, когда у разных исполнителей одинаковое название трека).

Учитывать тег "Последний запуск" - включает защиту от повторов, используя тег "Последний запуск".

Опцию Читать дополнительную информацию о файле надо держать включенной, если используются приоритеты, фильтры, а также нужно учесть настройки треков, сделанных в Track Tool. Информация всегда перечитывается, даже если источник треков музыкальная база.

Защита от повторов: учитывать треки в окне плейлиста - учитывает правила неповторения треков, находящихся в плейлисте.

Создавать пустой плейлист при ошибке - если при генерации плейлиста произошла ошибка, то будет создан пустой плейлист.

Фильтр поврежденных треков - фильтровать треки, которые не могут быть запущены (поврежденные файлы, неподдерживаемый формат и т.п.)

Учесть кроссфейды - учесть время наложения треков.


Автоматическое создание плейлиста

Инструкции по автоматическому созданию плейлистов с помощью программы Playlist Generator Pro, запускаемой по расписанию.

Сначала создайте и сохраните пресет (предварительную установку) в программе Playlist Generator Pro. В приведенном ниже примере пресет называется «Day».

После создания пресета закройте Playlist Generator Pro, а затем сделайте следующее:

1. Создайте в программе RadioBOSS новое запланированное задание.

2. Щелкните по кнопке вызова мастера. В окне мастера выберите действие «Создать плейлист» и щелкните кнопку «Далее».

В следующем окне мастера выберите шаблон. Щелкните «Далее». Соответствующая команда будет создана и вставлена в поле «Имя файла трека/плейлиста или команда» диалогового окна «Заданиe».

Необязательно каждый раз использовать мастер. Для создания плейлиста при помощи программы Playlist Generator Pro также можно воспользоваться следующей командой:

generate [pro] название_пресета

(Замените название_пресета на название нужного пресета.)

После того, как задание создано, программа RadioBOSS будет в заданное время автоматически создавать плейлисты и запускать их воспроизведение.

Если нужно просто создать и сохранить плейлист, без воспроизведения, то нужно поставить опцию "Сохранить созданный плейлист в файл (не запускать)" и указать имя файла.


Создание нескольких плейлистов

Генератор плейлистов позволяет создать несколько плейлистов за один раз. При генерации используется общий буфер неповторения треков, что позволяет использовать длинные интервалы неповторения треков (например, несколько дней). Для создания нескольких плейлистов выберите опцию Создать несколько плейлистов...

Откроется окно с настройками генерирования плейлиста:

Для создания плейлистов выберите пресеты, по которым плейлисты будут создаваться, нажатием на кнопку "+". Для каждого пресета нужно задать имя файла, куда будет сохранен созданный плейлист. Все плейлисты сохраняются в заданную папку.

Опции "Количество плейлистов" задает количество плейлистов, которое нужно создать для каждого пресета из списка. В случае, если количество плейлистов больше 1, то в имени файла нужно использовать модификаторы.

Модификаторы имени файла:

%n - число (1, 2, ... 10, ... 100).

%nn - число с одним ведущим нулем (01, 02, ..., 10, 100).

%nnn - число с двумя ведущими нулями (001, 002, ..., 010, 100)

Например, если запустить генерацию плейлистов как указано на скриншоте, то в папке D:\Music будет создано 5 плейлистов с именами:

D:\Music\playlist_01.m3u8

D:\Music\playlist_02.m3u8

D:\Music\playlist_03.m3u8

D:\Music\playlist_04.m3u8

D:\Music\playlist_05.m3u8

Нажатие на стрелку около кнопки Генерировать позволяет выполнить дополнительные действия:

Создать задание - добавляет задание в RaidoBOSS для создания и сохранения плейлистов по расписанию.

Скопировать командную строку - копирует командную строку для создания и сохранения плейлистов.


Параметры командной строки

Параметры командной строки программы Playlist Generator Pro

Для автоматического создания и сохранения плейлистов в указанное место можно использовать интерфейс командной строки.

Синтаксис: PlaylistGeneratorPro.exe -preset=PRESET -out=PLAYLIST [-n=N]

Опции:

-preset= задает имя пресета

-out= задает имя файла, в который будет сохранен созданный плейлист (используйте полное имя файла, включая путь, с расширением .m3u8)

-n= количество плейлистов, которое нужно создать (по умолчанию = 1). Если используется эта опция, то параметр -out должен содержать один из модификаторов: %n, %nn or %nnn (подробная информация ниже)

-s= если используется "-n", эта опция задает начальный номер для нумерации плейлистов. Например: -s=5

Пример:

PlaylistGeneratorPro.exe -preset=MyPreset -out=C:\playlist.m3u8

Внимание: Если имя пресета или сохраняемого плейлиста содержит пробел, то параметры нужно заключить в кавычки:

PlaylistGeneratorPro.exe "-preset=My Preset" "-out=C:\Folder name\playlist.m3u8"

Для создания плейлистов и сохранения их в указанное место можно использовать команду run в планировщике с интерфейсом командной строки. В отличие от автоматического создания плейлиста, плейлист будет лишь сохранен, но не запущен.

Пример:

(для программы PlaylistGeneratorPro.exe не нужно указывать полный путь):

run PlaylistGeneratorPro.exe -preset=MyPreset -out=C:\playlist.m3u8

Создание нескольких плейлистов за один раз (параметр -n)

Когда создаются несколько плейлистов за раз, используется один буфер для функций "не повторять..." - это означает, что можно создавать несколько плейлистов на длительные промежутки времени без повторяющихся треков.

Пример:

PlaylistGeneratorPro.exe -preset=MyPreset -out=C:\playlist_%nn.m3u8 -n=11

Внимание: Если команда выполняется в .bat файле, знак процента нужно писать два раза:

PlaylistGeneratorPro.exe -preset=MyPreset -out=C:\playlist_%%nn.m3u8 -n=11

Эта команда создаст 11 плейлистов и сохранит их под именами:

C:\playlist_00.m3u8

C:\playlist_01.m3u8

C:\playlist_02.m3u8

...

C:\playlist_10.m3u8

Модификаторы имени файла:

%n - число (1, 2, ... 10, ... 100).

%nn - число с одним ведущим нулем (01, 02, ..., 10, 100).

%nnn - число с двумя ведущими нулями (001, 002, ..., 010, 100)

Генерация нескольких плейлистов, используя несколько пресетов в одном запуске

Следующий пример поможет создать 3 плейлиста, используя Morning, Day и Evening пресеты, и сохранить их в D:\Playlists\Morning.m3u8, D:\Playlists\Day.m3u8, и D:\Playlists\Evening.m3u8. Это позволяет подготовить плейлисты заранее и использовать их, когда это необходимо.

Когда создаются несколько плейлистов за раз, используется один буфер для функций "не повторять..." - это означает, что можно создавать несколько плейлистов на длительные промежутки времени без повторяющихся треков.

Пример:

PlaylistGeneratorPro.exe "-preset=Morning|Day|Evening" "-out=D:\Playlists\Morning.m3u8|Day.m3u8|Evening.m3u8"

Можно указать полный путь только для первого плейлиста, тогда все плейлисты будут сохранены в одну папку. Можно указать полный путь для всех плейлистов.


Редактор кроссфейдов

Редактор кроссфейдов можно открыть из плейлиста. Для этого щелкните правой кнопки мыши по нужному треку и выберите «Редактор кроссфейдов» (если будете редактировать 2 трека) или «Редактор кроссфейдов 3» (если будете редактировать 3 трека).

Откроется следующее окно:

Пример: Редактор кроссфейдов для двух треков

Красная линия показывает уровень громкости трека. Для перемещения треков и квадратиков воспользуйтесь мышью.

Заданные параметры для кроссфейдов сохраняются в плейлисте. При перезапуске программы заданные параметры остаются. Чтобы сохранить плейлист в RadioBOSS в главном меню выберите Файл -> Сохранить (или Сохранить как...).


Параметры трека

Опция Параметры трека (Track Tool) позволяет установить параметры трека: интро, аутро, начало, конец и прочие.

Для запуска данной опции кликните правой кнопкой мыши на треке и выберите Параметры трека.

Начало - позиция, с которой будет начато воспроизведение трека.

Конец - конец воспроизведения трека.

Интро, аутро - эти параметры используются для воспроизведения голосовых треков.

Fade In, Mix, Fade Out - индивидуальные параметры кроссфейдов.

Hook In, Hook Out - установка места для нарезки трека, для использования в функции Нарезок.

Войсдроп - установка места для вставки войсдропа.

Уровень - установить уровень воспроизведения трека.

Чтобы показать или убрать редактор тегов нажмите на темную полоску справа.

В редакторе вы можете менять масштаб колесом мыши с нажатым Ctrl, также масштаб можно изменять через меню по правой кнопке на графике.

Вы можете остановить воспроизведение трека, нажав пробел.

Если активирована опция Исключить трек, то генератор плейлистов не будет использовать данный трек при создании плейлистов.

Кнопка Даты начала/конца трека используется для установки начальной и конечной даты воспроизведения трека. Если опция установлена, трек будет воспроизводиться только в указанные даты. Данная функция необходима для того, чтобы конкретные треки появлялись в плейлисте в определенные даты (например, треки на Новый год). Для работы данной функции необходимо обязательно указывать обе даты начала и конца воспроизведения трека!

Опции Исключить трек и Даты начала/конца трека функционируют только когда используются Генератор плейлистов и Track List


Менеджер рекламы

Данная программа предназначена для автоматического создания рекламных блоков и внесения их в расписание.

Чтобы запустить Менеджер рекламы, выберите Инструменты -> Менеджер рекламы

Использование программы

Первоначальная настройка

1) При первом запуске программы откройте окно настроек. (Программа сама предложит вам открыть это окно, просто щелкните по кнопке «Да».)

2) Задайте рабочую папку для сохранения плейлистов и заданий.

3) На вкладке «Настройка блоков» задайте время (часы и минуты) для вставки рекламы. Эти параметры можно будет потом изменить.

4) Нажмите OK.

Действия

·В главном окне программы щелкните по кнопке Добавить и добавьте треки. Эти треки будут внесены в список.

·Чтобы добавить трек в блок, отметьте галочкой нужное место в таблице (можно использовать любой из этих способов: щелчок правой кнопкой мыши, двойной щелчок левой кнопкой мыши или нажатие клавиши пробела).

·После внесения всех треков в таблицу щелкните по кнопке «Создать плейлисты и задания». Будут созданы файлы плейлистов для каждого рекламного блока, а также задания в планировщике на запуск этих плейлистов в заданное время. Задания будут автоматически внесены в Планировщик программы RadioBOSS.

·Внимание! Для срабатывания начальной и конечной даты роликов необходимо настроить автоматическое обновление рекламных плейлистов и заданий.

Цвет ролика в списке показывает его статус:

красный цвет - данного ролика нет на диске;

серый цвет - прогон ролика закончен по указанной дате;

синий цвет - дата начала прогона ролика запланирована в будущем;

черный цвет - ролик активен;

светло-серый - ролик отключен.

Вы можете загружать, сохранять, вставлять нужный вам пресет сетки. Для этого под сеткой роликов нажмите кнопку Правка внизу сетки "Свойства выделенного ролика".

Вам доступен медиаплан блоков, т.е. вы можете просматривать блоки (все или только выделенные): нажмите на кнопку Просмотр блоков и выберите необходимый вам вариант просмотра.

Вы можете задать желаемую длительность блоков: нажмите на кнопку Настройка блоков -> Добивки.

Кнопка Проверить все блоки позволяет проверить все блоки. Проверяются параметры: есть ли в блоке подряд два и более трека, принадлежащих к одному типу, а также превышение блоком допустимой длительности (задается в настройках).


Автоматическое обновление рекламных плейлистов и заданий

Для того, чтобы учитывались настройки начала и окончания проката рекламных роликов, нужно периодически обновлять рекламные плейлисты и задания. Для этого нажмите кнопку "Создать плейлисты и задания", и в появившемся окне включите опцию "Создать задание для обновления рекламных плейлистов". Выберите период обновления - каждый час или раз в день. Если ставить и снимать ролики нужно с точностью до часа, то обновление должно происходить раз в час.

Задание можно также создать вручную, добавив задание в планирощик с командой adsupdate.


Настройки роликов

Включить - включить/выключить рекламный ролик.

Начало - задать дату и час (включительно) начала проката рекламного ролика.

Конец - задать дату и час (включительно) окончания проката рекламного ролика.

Приоритет - задать приоритет рекламного ролика с 1 до 9. Приоритет определяет положение ролика в блоке (1 ближе к началу; 9 ближе к концу).

Тип - задать тип рекламного ролика. Тип ролика используется для вывода предупреждений в случае, когда два и более ролика одного типа стоят рядом (например, две рекламы пиццерии подряд).

Доп. треки - назначить дополнительные треки к рекламному ролику. Дополнительные ролики используются при создании блоков: при добавлении ролика в блок выбирается случайный ролик (основной или один из дополнительных).

Группа в списке - выбрать группу в списке.

Комментарий - написать комментарий, заметку к рекламному ролику.


Настройки

Чтобы открыть окно с настройками рекламных роликов в меню нажмите Настройки -> Настройки...

Настройки менеджера рекламы:

Общие

Настройки задания

Блоки

Прочее


Настройки

Рабочая папка - выбрать папку, в которую будут сохраняться созданные плейлисты и задания.

Создавать плейлисты для пустых блоков - создавать плейлисты для блоков, в которых нет рекламных роликов.

Для пустых блоков вы можете Добавить влет, Добавить вылет, Вставить добивки.

Формат сохранения плейлиста - выбрать формат сохраненного плейлиста. Желательно использовать m3u8 (по умолчанию).

Шаблон имени файла плейлиста - указать шаблон файла для создаваемых плейлистов.


Настройки задания

Рекламный планировщик создает задания с данными настройками.

Настройки задания аналогичны настройкам в планировщике RadioBOSS.


Блоки

В разделе Блоки вы можете указать часы и минуты, в которые планируется запускать рекламу. Выбранные блоки появятся в главном окне Менеджера рекламы в сетке, где для каждого ролика можно будет задать его наличие в каждом блоке.

Также вы можете настроить Влет блока, Вылет блока, Добивки и Разделители между роликами.

Влет блока, Вылет блока - вставить влет и вылет рекламного блока. Влет - трек, который играет в начале рекламного блока, вылет - в конце рекламного блока. При выборе Track List или Плейлист будет выбран один трек из папки или плейлиста. Кнопка Трек - указать конкретный трек.

Добивки - задать настройки для добивки рекламного блока до нужной длительности.

Разделители - вставить разделители между рекламными роликами. Будет выбран один случайный ролик из папки.


Прочее

Предупреждать, если блок длиннее чем заданное значение - указать время длительности блока, выше которого будет предупреждение. Ноль - не выводить предупреждение.


Микрофон

В программе RadioBOSS есть возможность использовать микрофон в любое время вещания.

Примечание: Если вы используете микшерный пульт, то функция микрофона вам не нужна, вы можете подсоединить микрофон непосредственно в микшерный пульт.

Для включения микрофона:

В первую очередь проверьте правильность выбора устройства и входа для микрофона: настройки микрофона.

Нажмите кнопку

в правом нижнем углу окна RadioBOSS.

В настройках выберите один из двух режимов работы кнопки MIC:

·Вкл/Выкл: Микрофон работает до тех пор, пора нажата кнопка. (Чтобы выключить микрофон нажмите кнопку еще раз.)

·В настройках можно включить опцию Push-To-Talk: микрофон будет работать пока вы держите нажатой кнопку MIC.

Дополнительно:

Настройки микрофона


Линейный вход

RadioBOSS позволяет использовать линейный вход в плейлисте. Параметры линейного входа настраиваются в окне настроек на вкладке Микрофон/Лин. вход

Линейный вход может быть использован для ретрансляции сигнала, поступающего на вход звуковой карты.

Для добавления линейного входа в плейлист, в меню выберите Плейлист -> Добавить линейный вход...

Появится окно, в котором можно выбрать желаемую длительность воспроизведения (или играть без ограничений по времени).

Данная опция не будет показана в меню, если не выбрано устройство в настройках.

Линейный вход появится как трек в плейлисте. Большинство эффектов, а также кроссфейды применяются к линейному входу.


Интернет-потоки и Podcast

Для вставки интернет-потока или подкаста в плейлист, в меню Плейлист нажмите кнопку - > " Добавить URL"...

Откроется окно, где вы можете ввести URL-адрес потока и установить длительность:

Если введен адрес подкаста (XML файла с подкастом), то поставьте галочку Podcast: в этом случае, RadioBOSS выберет новейший подкаст из списка и воспроизведет его.

Когда продолжительность интернет-потока равна 0 (нулю), RadioBOSS будет воспроизводить треки до конца (или до тех пор, пока что-то другое не начнется в плейлисте). Если продолжительность не равна нулю, RadioBOSS будет играть интернет-потоки в течение заданного промежутка времени, перезапуск интернет-потоков происходит в случае любой ошибки, например, ошибки соединения.Внимание! Потоки без указания длительности (0) не будут перезапущены при ошибке.


Карт-машина

Карт-машина - это треки быстрого доступа, которые могут быть запущены вместе с плейлистом.

Для добавления карт-машины: нажмите кнопку "+" и выберите "Карт-Машина":

Появится сетка 5х5:

Чтобы назначить трек: кликните правой кнопкой мыши на ячейке и выберите "Изменить...". В появившемся окне выберите трек, цвет ячейки и название. Нажмите OK.

В качестве имени файла вы можете указать line.in или line2.in для воспроизведения линейного входа. Чтобы остановить проигрывание всех треков карт-машины, укажите имя файла stopall. Карт-машина также поддерживает шаблоны имени файла планировщика.

При заполнении ячеек вы можете перетаскивать треки из проводника, а также перетаскивать треки между ячейками.

После того, как ячейки настроены, можно запускать треки нажатием по ячейке. Повторное нажатие во время воспроизведения останавливает трек. В нижнем левом углу будет показано оставшееся время воспроизведения. Чтобы остановить воспроизведение, нажмите кнопку ячейки снова. Щелкните правой кнопкой мыши ячейку, чтобы изменить его или включить цикл.

Карт-машину можно выводить на отдельную звуковую карту: настройки воспроизведения.

Щелкните правой кнопкой мыши, чтобы сохранить или загрузить ячейки карт-машины.

Вы можете изменять размер сетки карт-машины. Для этого нажмите правой кнопкой мыши на вкладку и выберите "Изменить размер сетки". У вас появится окно, в котором можете указать желаемое количество колонок и строк.

Если вы уменьшите количество ячеек, то все ячейки, которые не помещаются в новую сетку, будут удалены.

Для карт-машины доступна функция горячая клавиша. Нажмите правой кнопкой мыши на вкладку карт-машины, выберите "Горячая клавиша" и удобный для вас вариант.

Если вы выбрали кнопку "Ctrl", то чтобы прослушать трек, нажмите "Ctrl" потом кнопку, под которой находится выбранный трек. Например, если вы хотите прослушать трек под цифрой 2, то нажмите "Ctrl", потом отдельно "2"; если трек находится под буквой М, то нажмите "Ctrl", потом отдельно "М".

Если вы хотите остановить трек, то нажмите то же самое еще раз. Аналогично, если вы выбрали кнопку "Shift".

Вы можете сделать несколько рабочих зон для карт-машины. Нажмите "Ctrl+2", если вы хотите сделать 2 рабочие зоны, нажмите "Ctrl+3", если хотите сделать 3 рабочие зоны.


Типы файлов

В плейлисте могут быть файлы различных типов. Для каждого типа файлов задается цвет, которым будут выделены все треки данного типа в плейлисте, кроссфейды и уровень усиления при воспроизведении (-20 to +20 dB). Файлы, которые не принадлежат к какому-либо типу, обрабатываются как "Музыка" при применении параметров кроссфейдов.

Принадлежность трека к типу можно определить несколькими способами:

1. Указать папку в поле Папка типа файла. Если указана папка, все треки, находящиеся в этой папке (и в подпапках) будут считаться треками заданного типа.

2. Указать идентификатор. Идентификатор - это слово или любая последовательность символов, служит для того, чтобы определить к какой группе принадлежит файл. Тип файла можно

назначить через идентификатор в теге файла: идентификатор ищется в теговой информации (название/исполнитель), или в имени файла, если тег у файла отсутствует. Не рекомендуется использовать короткие идентификаторы, которые могут появиться как часть названия трека - например, идентификатор "id", котоый может быть найден по названию трека "The Beatles - Everybody's Got Something to Hide". Лучше использовать "id:" (добавить двоеточие до и/или после идентификатора) или выбрать другой идентификатор. Чтобы задать тип файла для воспроизведения интернет-потоков, используйте идентификатор :// (или любую часть адреса потока, например, имя домена). Тип файла для автоматического объявления времени должен иметь идентификатор saytime.

3. Тип файла можно назначить через Track Tool. Задать тип файла одновременно для нескольких треков можно через Music Library.

Например, первая группа имеет название "Реклама", идентификатор "РекламныйТрек", красный цвет и усиление +5дБ. В этом случае, все треки, содержащие в тегах (название и исполнитель) или имени файла слово "РекламныйТрек" будут выделены в плейлисте красным цветом и проигрываться громче остальных (+5дБ). Файл будет миксоваться в соответствие с настройками кроссфейдов для группы "Реклама".

Описание настроек:

Название | Название типа файла
Идентификатор | Определяет к какому типу принадлежит файл
Идентификатор в | Искать идентификатор в теге файла или в имени файла
Папка типа файла | Все треки, находящиеся в этой папке (и в подпапках) будут считаться треками заданного типа
Цвет в плейлисте | Вы можете установить любой цвет шрифта или фона выбранного файла
Amp | Изменение уровня громкости в сторону снижения или усиления, когда играет трек данного типа файла
Включать треки этого типа в отчет | Опция позволит включать треки выбранного типа в отчет
Обрабатывать как голосовой трек | Активировав данную опцию, файлы будут играть как голосовые треки
Не отправлять название на сервер | Опция позволит не отправлять название трека на сервер
Использовать произвольный формат | Вы можете использовать любой произвольный формат названия трека: исполнитель, название трека, год, альбом, жанр, обозначение времени и т.д. Описание переменных
Использовать подложку | Опция позволяет к выбранному типу прикрепить подложку - файл, который будет играть на фоне основного и установить его уровень
Пропускать после задания | После воспроизведения задания выбранный тип файла, стоящий в очереди на воспроизведение, не будет проигрывать
Не играть подряд два трека этого типа | Опция позволит вам установить неповторяемость воспроизведения выбранного типа файла

Для создания типа файлов:

1. В меню выберите Настройки -> Настройки...

2. Выберите Типы файлов.

3. Введите имя нового типа файла в поле Название.

4. Введите идентификатор типа файла в поле Идентификатор.

5. Выберите цвет шрифта и фона.

6. Переместите ползунок Amp, чтобы установить уровень усиления громкости, если это необходимо.

7. Нажмите OK.

Дополнительно:

RadioBOSS. Quick start.


Кроссфейды

В окне «Кроссфейды» можно задать точку микширования, а также параметры автоподъема и автозатухания для музыкальных и других файлов.

Чтобы открыть это окно в меню нажмите Настройки > Кроссфейды.

Элементы управления и опции:

Точка автоподъема

Интервал в начале трека, на протяжении которого громкость линейно нарастает от 0 до 100%.

Точка микширования

Интервал в конце трека, когда (с наложением) начинается воспроизведение следующего трека.

Начинать микс при уровне

Опция «Начинать микс на уровне» основана на уровне громкости звука (по умолчанию –14 дБ). При использовании этой опции необходимо также включить опцию «Точка микширования».

При включенной опции параметр «Точка микширования» (по умолчанию 2,5 сек.) задает минимальную длительность перекрытия треков.

Точка автозатухания

Интервал в конце трека, на протяжении которого громкость уменьшается.

Начинать автозатухание при миксе

Если эта опция включена, то автозатухание будет запущено одновременно с микшированием; при этом параметр «Точка автозатухания» задает длительность автозатухания.

Выбор типа файла

Выбор типа файла, для которого будут меняться настройки кроссфейда.

Изменить микс предыдущего трека

Опция контролирует на сколько трек будет наложен на предыдущий. Функция полезна для рекламных роликов и джинглов во избежание длинных наложений с предыдущим музыкальным треком.

Типы файлов...

Редактировать типы файлов.

Подробнее:

Использование файлов разных типов


Использование функции Track list

Функция "Список треков" позволяет добавить в плейлист специальный элемент, при запуске которого будет проигрываться один трек из заданной папки/плейлиста. Треки выбираются одним из двух методов: случайно или по порядку.

Список треков выглядит в плейлисте как один файл.

Чтобы добавить Track List:

1. В меню выберите Плейлист -> Добавить Track List...

2. В появившемся окне, выберите источник треков (папку или плейлист) и способ выбора треков.

Когда вы выбираете папку, вы также можете включить опцию "Включая подпапки", чтобы добавить треки из подпапок.

3. Выберите метод выбора треков:

·Случайно - треки будут выбираться в случайном порядке. RadioBOSS будет избегать повторения треков, кроме тех, которые играют непосредственно с источника.

·По порядку - треки будут выбираться по порядку (при использовании папок треки будут играть по алфавиту).

·Сериал - треки будут выбираться по порядку, но позиция в источнике не будет продвигаться автоматически: тот же трек будет выбираться до тех пор, пока позиция в списке не будет увеличена. Чтобы увеличить позицию, нужно использовать задание в планировщике: чтобы добавить задание нажмите кнопку Создать задание...

Задание для увеличения позиции может быть добавлено позже в любое время:

Вариант 1. Добавьте задание и используйте Кнопку мастера: выберите Запустить один трек из папки или плейлиста -> нажмите кнопку Далее -> Запустить один трек из папки или плейлиста (Track List) -> нажмите кнопку Далее -> выберите тот же источник треков и убедитесь, что опция "Включая подпапки" находится в том же состоянии. Нажмите кнопку Создать задание.

Вариант 2. Правой кнопкой мыши нажмите на файл Track List в плейлисте, выберите Дополнительно -> Переименовать/изменить. Нажмите кнопку Создать задание.

Нажмите кнопку Защита от повторов чтобы установить параметры защиты треков от повторения.

Параметры защиты треков от повторения применяются ко всем Track List, которые используются в RadioBOSS. Track List может игнорировать правила защиты от повторов: поставьте галочку Игнорировать правила неповторения (полезно для джинглов, идентификаторов станции и аналогичных треков, которые не должны быть ограничены правилами неповторения).

Дополнительно:

Генерация плейлиста


Музыкальная база

Создание музыкальной базы нужно для работы генератора плейлистов и быстрого поиска из плеера.

Для создания музыкальной базы:

1. В программе RadioBOSS в меню нажмите Инструменты > Музыкальная база

Появится окно программы Music Library.

Теперь можно добавлять файлы или папки в музыкальную базу.

2. Для добавления папки, нажмите Добавить > Добавить папку...

В этом же меню указываются опции добавления, какие типы файлов добавлять (видео или аудио) и добавлять ли файлы, уже имеющиеся в базе. Эта опция позволяет быстро обновлять базу, если в папку с музыкой было добавлено несколько новых треков.

3. Сохраните базу в файл, меню Файл > Сохранить. Для начала рекомендуется сохранять базу в путь по умолчанию.

В меню Сервис доступны дополнительные команды.

Проверить треки - проверить треки на поврежденность. После проверки программа выдаст список треков, которые имеют проблемы. Опция также позволяет проверять теги треков.

Сканировать и отрезать тишину - сканировать треки и установить метки начала и окончания трека, отрезав тишину. Порог отрезания тишины задается в настройках RadioBOSS.

Сканировать ВРМ - сканировать треки и прописать тег BPM.

Запланировать автообновление базы... - данная команда создаст задание в RadioBOSS, которое будет сканировать заданные папки и создавать из них базу.

Вы можете выделять треки колесом мыши.

Пользовательские поля в тегах

Музыкальная база позволяет определять до 5 пользовательских полей. Пользовательские поля отображаются в редакторах тега (Track Tool и в общем редактировании тега в музыкальной базе) и также могут быть использованы в Генераторе отчетов.

Дополнительно:

Playlist Generator

Поиск


Голосовые треки

В программе RadioBOSS есть функция для записи и воспроизведения голосовых треков.

Для работы с голосовыми треками используйте соответствующие команды меню Плейлист.

Для записи голосовых треков запустится специальная программа:

Для записи используется то же устройство, которое выбрано для микрофона: MIC.

Нажмите кнопку Запись для начала записи. Чтобы завершить запись нажмите Стоп. Прослушать можно нажатием на кнопку Play. Для воспроизведения используется звуковая карта, установленная для прослушки.

Команды Правка могут быть использованы для редактирования трека.

Для вставки голосового трека в плейлист используйте команду Вставить голосовой трек - он будет отмечен курсивом в плейлисте.

Голосовые треки запускаются автоматически в промежутке Интро/Аутро треков.

Эти параметры настраиваются используя модуль Track Tool.

Пример того, как будет запущен войстрек:

Красный - это Аутро первого трека, Зеленый - Интро второго трека. Для коротких голосовых треков (короче, чем Интро+Аутро) голосовой трек будет запущен ближе к окончанию интро второго трека.

Некоторые настройки воспроизведения голосовых треков есть в разделе Настройки-Воспроизведение-Фейды

Краткая справка:

Интро - вводная часть трека до того, как исполнитель начинает петь

Аутро - завершающая часть трека, например, инструментальное соло


Войсдропы

Войсдропы - вставка голоса в указанное место музыкального трека.

Место для вставки войсдропа задается в Track Tool.

После того, как место для войсдропа установлено, для настройки параметров войсдропа нажмите на кнопку "..." в Track Tool. Прослушать место установки можно нажатием правой кнопки мыши на "...".

Параметры войсдропа

Голосовая вставка - выбирается файл или папка с войсдропами. В случае, если выбрана папка, из нее каждый раз будет выбираться случайный файл.

Позиция - устанавливает режим работы метки, Начало - войсдроп будет начат в указаном месте. Конец - войсдроп закончится в указанном месте.

Вероятность - задается вероятность выхода войсдропа.

Для трека с установленным войсдропом, войсдроп обозначается розовым в окне "В эфире".

Войсдропы можно включать и выключать (например, отключить для ночного эфира) используя команды планировщика enablevo, disablevo.


Авто Интро

Функция Авто Интро позволяет автоматически вставлять джинглы до начала треков.

Чтобы использовать Авто Интро в главном меню нажмите Инструменты -> Авто Интро.

Откроется окно с настройками Авто Интро, где вы можете задать правила для автоматических джинглов.

Для добавления нового правила нажмите кнопку Добавить. Используйте кнопку Редактировать для изменения выбранного правила. Кнопки вверх/вниз используются для перемещения правил в списке.

Приоритет правила основывается на месте в списке: чем выше правило в списке, тем выше приоритет. Если трек подходит под два и более правила, то будет использовано правило, расположенное в списке выше.

Окно с правилами для Авто Интро:

Вы можете задать следующие параметры для правил:

Название - название в списке. Название также используется командой планировщика autointro для включения и выключения правил.

Интро треки - установить список джинглов. Это может быть один файл, плейлист или папка. В случае плейлиста или папки, будет выбираться один случайный джингл.

Вероятность - установить вероятность вставки джингла. 100% - всегда, 33% - в среднем, вставить один джингл на каждые три трека.

Условие - если установить, джингл будет вставлен в случае соответствия музыкального трека заданным критериям. Например, условие может быть использовано для применения авто интро для треков с определенным жанром или для треков с конкретным исполнителем. При проверке условия регистр символов не учитывается.

Позиция на треке - установить позицию авто интро джингла на треке. Выбирается тип позиции: Начать или Закончить - позиция где джингл будет начат или закончен, соответственно. Затем устанавливается временное значение в секундах или это может быть специальное значение: Интро или Фейд ин. Например, если позиция установлена Закончить: Фейд ин, джингл закончит воспроизведение в то время, когда музыкальный трек закончит автоподъем громкости. Если позиция установлена Закончить: 3.5 - джингл будет закончен через 3,5 секунды после начала музыкального трека.


Нарезки

Нарезки - автоматическое создание нарезок из треков. Задаются джинглы начала, перехода между треками, конца. Для музыкальных файлов могут использоваться установленные метки места нарезки (задаются через Track Tool - метки Hook In и Hook Out), либо автоматическое определение места нарезки в треке (AutoHook). В качестве источника треков для нарезки может выступать папка с треками, или следующие плейлисту треки (после играющего). При анонсе следующих треков, нарезки работают только если выключен режим "Shuffle", также, используются только обычные треки: пропускаются специальные элементы вроде Track List, интернет-потоки, команды и т.п.

Для добавления нарезки в плейлист в меню нажмите Плейлист -> Добавить нарезки.

Для воспроизведения нарезки через планировщик в мастере нужно выбрать Автоматическое объявление - Нарезки.

Для настройки типа файла для нарезок, используйте идентификатор teaser=.

Общая структура нарезки

oДжингл начала

oНарезка трека 1

oПереход

oНарезка трека 2

oПереход

oНарезка трека 3

oПереход

oНарезка трека 4

oДжингл окончания

Джинглы начала, конца и перехода не являются обязательными.

Между элементами нарезки используется кроссфейд, его параметры задаются в окне настроек нарезок (кнопка Настройки в окне добавления нарезок).

Начало, Переход, Конец - задаются, соответственно, джинглы начала, перехода и конца. Можно выбрать папку (в этом случае из нее будет выбран случаный файл) или файл. Если джингл не нужен - поле должно быть пустым.

Треки - выбор источника треков:

oСледующие по плейлисту - используется заданное количество треков, следующих после играющего в плейлисте. Количество треков - задается количество треков из которых будут выбираться треки для нарезки.

oТреки из папки - выбрать треки из папки.

Количество в нарезке - устанавливается количество треков в нарезке: из источника будет выбрано это количество треков

Перемешать треки - из источника будут выбраны случайные треки

AutoHook для треков без установленных меток нарезки - для треков без установленных меток Hook In и Hook Out место нарезки будет определено автоматически.

oДлительность - длительность автоматических меток для AutoHook.

Настройки - кнопка для вызова окна настроек нарезок.

Переходы - задаются параметры кроссфейдов для перехода между элементами нарезки. Смысл настроек аналогичен настройкам кроссфейдов.

Исключения - исключение треков из нарезки. Позволяет исключить очень длинные и очень короткие треки, а также исключить типы файлов (например, новости, рекламы и т.п.).


Генератор отчетов

В состав RadioBOSS входит генератор отчетов о проигранных треках.

Чтобы запустить его, выберите Инструменты -> Генератор отчетов.

Окно генератора отчетов:

В этом окне можно выбирать период, за который нужно создать отчет, тип отчета и поля: название, исполнитель, альбом, год, жанр, комментарий, кол-во воспроизведений, длительность и др.

Кол-во воспроизведений - каждый трек в отчете появится только один раз и будет указано количество его выходов.

Список - отчет будет в виде списка проигранных треков.

Отчет может быть отсортирован по заданным критериям. Для сортировки выберите поле Сортировка (Исполнитель, название, альбом, год...) и Направление (По возрастанию и по убыванию).

Выберите поля, которые хотите видеть в отчете. Время начала отчета берется с 00 минуты часа, время окончания отчета до 59 минуты часа включительно. Например, чтобы сделать отчет за один час (8:00-8:59), необходимо указывать время с 8 до 8.

После того, как все настроено, нажмите Просмотр. Появится окно, в котором можно распечатать или сохранить отчет:


Редактирование тегов

В программе RadioBOSS есть встроенный редактор тегов, поддерживающий форматы ID3v1, ID3v2, MP4, WMA и др. Пользовательский интерфейс редактора находится под окном плейлиста.

Если редактор тегов скрыт, совершите любые из нижеперечисленных действий:

* Нажмите Ctrl + I

* Щелкните по пиктограмме (i) под плейлистом

* Откройте редактор из меню: Просмотр -> Информация о треке

Внимание! Если начато редактирование тегов, то информация о треке не будет обновляться, пока изменения не будут сохранены или отменены (кнопки для сохранения и отмены изменений находятся в правом нижнем углу).

Если нет никакой информации о треке, то вы можете заполнить ее, для этого нажмите правой кнопкой мыши на панели информации и выберите "Заполнить название/исполнитель из имени файла". Чтобы сохранить тег, нажмите на значок Сохранить в углу справа.


Запись эфира

Запись эфира - необходимая функция любой радиостанции. Эта функция может использоваться как для архивации эфира, так и для подготовки предзаписанных шоу. В программе RadioBOSS вы легко сможете поставить эфир на запись.

Для этого в инструментах выберите Запись потока.

Или нажмите на панели инструментов Запись потока.

У вас появится окно, в котором вы можете установить все необходимые настройки для записи эфира. Также запись эфира можно начинать и останавливать автоматически streamarchive командой в расписании.


Виртуальные звуковые карты

В RadioBOSS вы можете использовать виртуальные звуковые карты - одну или несколько (количество карт не ограничено). Виртуальные карты встроены в программу и не требуют отдельной установки. Добавить или удалить карты, а также выбрать их для работы в RadioBOSS можно через настройки воспроизведения и записи.

Что такое виртуальная звуковая карта и зачем она нужна?

Виртуальные карты позволяют перенаправить звук из одной программы в другую. Например, с помощью виртуальных карт можно выпустить в эфир звонок Skype, или любой другой программы для общения голосом, можно перенаправить звук со спутникового ресивера или FM-тюнера в программу.

Каждая виртуальная карта представляет собой вход и выход, которые работают в паре: то, что подается на выход (например, карта выбрана в качестве устройства воспроизведения в какой-либо программе), можно получить на входе (например, выбрав соответствующее устройство в качестве линейного входа в RadioBOSS).

Виртуальные карты предоставлены компанией VB-Audio Software (www.vb-cable.com)


Удаленное управление через API

В программе RadioBOSS есть API для удаленного управления.

Включить этот API и сделать нужные настройки можно в окне «Настройки»: Настройка API для удаленного управления.

Информация по API для удаленного управления программой по протоколу HTTP

Удаленное управление по протоколу HTTP

Запросы:

Примечание. При создании строки запроса укажите в параметрах функцию кодирования URL (URL Encoding), например urlencode (http://www.php.net/manual/en/function.urlencode.php) в PHP. Запросы следует направлять в кодировке UTF8.

I. Выполнение команды. В данном API используются те же команды, что и в планировщике. Список команд: Команды планировщика

Некоторые команды не могут быть выполнены через API: getrandomplaylist, getfile, playrequestedsong

Синтаксис:

http://IP:Port/?pass=ПАРОЛЬ&cmd=КОМАНДА

(замените «ПАРОЛЬ» и «КОМАНДА» на соответствующие значения)

Пример 1. Воспроизведение следующего трека (команда: next)

http://127.0.0.1:9001/?pass=WxPe2JXh&cmd=next

Пример 2. Воспроизведение первого трека в плейлисте (команда: play 1)

http://127.0.0.1:9001/?pass=WxPe2JXh&cmd=play%201

II. Выполнение действия

Синтаксис:

http://IP:Port/?pass=ПАРОЛЬ&action=ДЕЙСТВИЕ

(замените «ПАРОЛЬ» и «ДЕЙСТВИЕ» на соответствующие значения)

Возможные значения параметра ДЕЙСТВИЕ:

playbackinfo

получить информацию о воспроизведении

Возвращаемые данные: XML, содержащий информацию о текущем и следующем треке, позицию в плейлисте и текущее состояние некоторых опций программы.

Пример:

http://127.0.0.1:9001/?pass=WxPe2JXh&action=playbackinfo

Пример возвращаемых данных: показать

<?xml version="1.0" encoding="utf-8"?>

<Info>

  <PrevTrack>

      <TRACK ARTIST="Metallica" TITLE="Battery" ALBUM="Master Of Puppets" YEAR="1986" GENRE="Metal" COMMENT="" FILENAME="D:\Metallica\Master of Puppets\01 Battery.m4a" DURATION="05:12" PLAYCOUNT="1" LASTPLAYED="2018-01-16 20:20:30" INTRO="0.00" OUTRO="0.00" LANGUAGE="" F1="" F2="" F3="" F4="" F5="" CASTTITLE="Metallica - Battery" />

  </PrevTrack>

  <CurrentTrack>

      <TRACK ARTIST="Metallica" TITLE="Master Of Puppets" ALBUM="Master Of Puppets" YEAR="1986" GENRE="Metal" COMMENT="" FILENAME="D:\Metallica\Master of Puppets\02 Master Of Puppets.m4a" DURATION="08:29" PLAYCOUNT="1" LASTPLAYED="2018-01-16 20:20:38" INTRO="0.00" OUTRO="0.00" LANGUAGE="" F1="" F2="" F3="" F4="" F5="" CASTTITLE="Metallica - Master Of Puppets" LISTENERS="0" />

  </CurrentTrack>

  <NextTrack>

      <TRACK ARTIST="Metallica" TITLE="The Thing That Should Not Be" ALBUM="Master Of Puppets" YEAR="1986" GENRE="Metal" COMMENT="" FILENAME="D:\Metallica\Master of Puppets\03 The Thing That Should Not Be.m4a" DURATION="06:36" PLAYCOUNT="0" LASTPLAYED="" INTRO="0.00" OUTRO="0.00" LANGUAGE="" F1="" F2="" F3="" F4="" F5="" CASTTITLE="Metallica - The Thing That Should Not Be" />

  </NextTrack>

  <Playback pos="8543" len="509416" state="play" playlistpos="4" />

  <Options repeat_list="0" shuffle="0" />

  <Features scheduler="0" />

</Info>

inserttrack

вставить трек в плейлист

Параметры:

"filename" — имя локального файла

"pos" — позиция в плейлисте, куда будет вставлен трек (1 ... N).

Другие возможные значения:

-1: вставить в конец плейлиста

-2: вставить после текущего трека

-3: вставить после заданий планировщика

"streamingtitle" — установить название вещания для вставленного трека

Пример:

Вставить трек “D:\music\track.mp3”

http://127.0.0.1:9001/?pass=WxPe2JXh&action=inserttrack&filename=D%3A%5Cmusic%5Ctrack.mp3&pos=-2

Возвращаемые данные: OK в случае успешного выполнения

library

скачать файл музыкальной базы (xml)

Параметры:

"filename" — имя файла музыкальной базы

Возвращаемые данные: содержимое файла музыкальной базы

Пример:

http://127.0.0.1:9001/?pass=WxPe2JXh&action=library&filename=Base

trackartwork

скачать обложку текущего трека

Возвращаемые данные: обложка текущего трека (или ничего, если обложка отсутствует)

nexttrackartwork

скачать обложку следующего трека

Возвращаемые данные: обложка следующего трека (или ничего, если обложки нет)

setnexttrack

установить следующий трек

Параметры:

"pos" — позиция в плейлисте трека, который будет выбран следующим (1 ... N)

Пример:

Выбрать первый трек в плейлисте в качестве следующего

http://127.0.0.1:9001/?pass=WxPe2JXh&action=setnexttrack&pos=1

Возвращаемые данные: OK в случае успешного выполнения

delete

удалить трек из плейлиста

Параметры:

"pos" — позиция трека в плейлисте, который нужно удалить (1 ... N)

Пример:

Удалить второй трек из плейлиста

http://127.0.0.1:9001/?pass=WxPe2JXh&action=delete&pos=2

Возвращаемые данные: OK в случае успешного выполнения

move

переместить трек в плейлисте

Параметры:

"pos1" — позиция трека, который нужно переместить

"pos2" — новая позиция трека

Возвращаемые данные: OK в случае успешного выполнения

mic

включить или выключить микрофон

Параметры:

"on" - 0 для выключения микрофона, 1 для включения. Если параметр пропущен, будет возвращен статус микрофона. При наличии параметра, возвращается OK в случае успешного выполнения

0 - выкл

1 - вкл

Пример (включить микрофон):

http://127.0.0.1:9001/?pass=WxPe2JXh&action=mic&on=1

Пример (query status):

http://127.0.0.1:9001/?pass=WxPe2JXh&action=mic

getplaylist

получить содержимое плейлиста

Возвращаемые данные: XML, содержащий информацию о треках, находящихся в активном плейлисте.

Пример возвращаемых данных: показать

<?xml version="1.0" encoding="utf-8"?>

<Playlist>

  <TRACK ARTIST="Metallica" TITLE="Battery" ALBUM="Master Of Puppets" YEAR="1986" GENRE="Metal" COMMENT="" FILENAME="D:\Metallica\Master of Puppets\01 Battery.m4a" DURATION="05:12" PLAYCOUNT="1" LASTPLAYED="2018-01-16 20:20:30" INTRO="0.00" OUTRO="0.00" LANGUAGE="" F1="" F2="" F3="" F4="" F5="" />

  <TRACK ARTIST="Metallica" TITLE="Master Of Puppets" ALBUM="Master Of Puppets" YEAR="1986" GENRE="Metal" COMMENT="" FILENAME="D:\Metallica\Master of Puppets\02 Master Of Puppets.m4a" DURATION="08:35" PLAYCOUNT="1" LASTPLAYED="2018-01-16 20:20:38" INTRO="0.00" OUTRO="0.00" LANGUAGE="" F1="" F2="" F3="" F4="" F5="" />

  <TRACK ARTIST="Metallica" TITLE="The Thing That Should Not Be" ALBUM="Master Of Puppets" YEAR="1986" GENRE="Metal" COMMENT="" FILENAME="D:\Metallica\Master of Puppets\03 The Thing That Should Not Be.m4a" DURATION="06:36" PLAYCOUNT="0" LASTPLAYED="" INTRO="0.00" OUTRO="0.00" LANGUAGE="" F1="" F2="" F3="" F4="" F5="" />

</Playlist>

getplaylist2

получить содержимое плейлиста (быстро)

Возвращаемые данные: XML, содержащий информацию о треках.

Параметры

"cnt" - максимальное количество треков в результате, 0 = все треки (необязательно)

Пример возвращаемых данных: показать

<?xml version="1.0" encoding="utf-8"?>

<Playlist COUNT="18">

  <TRACK STARTTIME="8:20:30 PM" CASTTITLE="Metallica - Battery" DURATION="05:12" FILENAME="D:\Metallica\Master of Puppets\01 Battery.m4a" RATING="0" PLAYCOUNT="1" INTRO="" OUTRO="" BPM="" PLAYLISTINDEX="0" INDEX="1" />

  <TRACK STARTTIME="8:20:38 PM" CASTTITLE="Metallica - Master Of Puppets" DURATION="08:35" FILENAME="D:\Metallica\Master of Puppets\02 Master Of Puppets.m4a" RATING="0" PLAYCOUNT="1" INTRO="" OUTRO="" BPM="" PLAYLISTINDEX="1" INDEX="2" />

  <TRACK STARTTIME="8:29:10 PM" CASTTITLE="Metallica - The Thing That Should Not Be" DURATION="06:36" FILENAME="D:\Metallica\Master of Puppets\03 The Thing That Should Not Be.m4a" RATING="0" PLAYCOUNT="0" INTRO="" OUTRO="" BPM="" PLAYLISTINDEX="2" INDEX="3" />

</Playlist>

trackinfo

получить информацию о треке

Параметры:

"pos" — позиция трека в плейлисте (1 ... N)

Пример:

http://127.0.0.1:9001/?pass=WxPe2JXh&action=trackinfo&pos=2

Пример возвращаемых данных: показать

<?xml version="1.0" encoding="utf-8"?>

<Info>

  <Track>

      <TRACK ARTIST="Metallica" TITLE="Master Of Puppets" ALBUM="Master Of Puppets" YEAR="1986" GENRE="Metal" COMMENT="" FILENAME="D:\Metallica\Master of Puppets\02 Master Of Puppets.m4a" DURATION="08:35" PLAYCOUNT="1" LASTPLAYED="2018-01-16 20:20:38" INTRO="0.00" OUTRO="0.00" LANGUAGE="" F1="" F2="" F3="" F4="" F5="" />

  </Track>

</Info>

songrequest

добавить запрос на песню

Параметры:

"filename" - имя файла запрошенного трека (полный путь на диске)

"message" - сообщение от пользователя (необязательно)

Чтобы просмотреть список запрошенных песен вручную в меню нажмите Вид - Запросы песен.

Чтобы автоматически воспроизвести песню из списка запрошенных, используйте команду playrequestedsong в планировщике.

Возвращаемые данные: OK в случае успешного выполнения

songrequestclear

очистить список запрошенных песен

Очистить список запрошенных песен

Возвращаемые данные: OK в случае успешного выполнения

songrequestlist

получить список запрошенных песен

Возвращаемые данные: XML с информацией о запрошенных треках. Показать пример

<?xml version="1.0" encoding="utf-8"?>

<SongRequest>

  <Request filename="C:\Music\Track01.mp3" message="The message" />

  <Request filename="C:\Music\Track08.mp3" message="Another message" />

</SongRequest>

encoderstatus

получить информацию о выходах вещания

Возвращаемые данные: XML, содержащий информацию о выходах вещания. Показать пример

<?xml version="1.0" encoding="utf-8"?>

<Encoders>

  <Encoder index="0" status="idle" />

  <Encoder index="1" status="off" />

  <Encoder index="2" status="active" />

</Encoders>

streamarchivestatus

получить информацию о записи потока

Получить статус функции Записи потока

0 - выкл

1 - вкл

schedule

управление планировщиком

Параметры

"type" - тип запроса, один из:

olist - получить список заданий (список всех заданий в формате XML)

odelete - удалить задание

orun - запустить задание

oadd - добавить задание

oupdate - редактировать задание

ostate - включить или выключить планировщик, а также получить статус планировщика

"event" - XML данные задания (когда type "update" или "add")

"id" - ID задания, можно получить выполнением запроса "list" (используется когда type "delete", "run" или "update")

"set" - on (включить) или off (выключить) (когда type - "state"), если параметр не указан - возвращается текущий статус планировщика

Возвращаемые значения:

·для запросов delete, run, add, update: OK в случае успешного выполнения

·для запроса state: on - планировщик включенб off - планировщик выключен

Пример XML со списком заданий

<?xml version="1.0" encoding="utf-8"?>

<Events>

<item EnabledEvent="True" UseDate="False" EveryYear="False" Imm="False" Above="False" FileName="generate [pro] 1h" MuteLev="50" DelPrev="True" DoNotRunIfStopped="False" bRepeat="True" nRepeatPer="60" DoNotMarkAsScheduled="False" nRepeat="1" RepeatLimit="False" TimeToStart="" Shuffle="False" PausePlaylist="False" UseWeeks="False" Enqueue="False" DelTaskAction="0" DelTaskUseDate="False" TaskName="Playlist" ClearMainPlaylist="False" UseDaysOfWeek="True" Hours="000000000000000000000000" Minutes="0" Seconds="0" TimeType="0" TaskNameAsTitle="False" IntTimeToStart="2147483647" ItemImageIndex="63" FontColor="-16777208" BackColor="-16777211" GroupName="" DTMFOn="False" DTMFString="" DTMFOnly="False" DTMFExitOn="False" DTMFExitString="" MaxTimeWaitOn="False" MaxTimeWaitSec="0" MaxTimeWaitAction="0" UseFillers="False" FillersSource="" FillersRecurse="True" FillerMaxAmount="120" Id="DKCODACFWSIKHULWXDUL" Days="1111111" Weeks="00000" Time="2018-02-17 00:00:00" DelTaskTime="2018-02-17 00:00:00" />

<item EnabledEvent="True" UseDate="False" EveryYear="False" Imm="False" Above="True" FileName="http://127.0.0.1:8092/live" MuteLev="50" DelPrev="True" DoNotRunIfStopped="False" bRepeat="False" nRepeatPer="10" DoNotMarkAsScheduled="False" nRepeat="1" RepeatLimit="False" TimeToStart="" Shuffle="False" PausePlaylist="False" UseWeeks="False" Enqueue="False" DelTaskAction="0" DelTaskUseDate="False" TaskName="" ClearMainPlaylist="False" UseDaysOfWeek="True" Hours="000000000000000000000000" Minutes="0" Seconds="0" TimeType="0" TaskNameAsTitle="False" IntTimeToStart="2147483647" ItemImageIndex="56" FontColor="-16777208" BackColor="-16777211" GroupName="" DTMFOn="False" DTMFString="" DTMFOnly="False" DTMFExitOn="False" DTMFExitString="" MaxTimeWaitOn="False" MaxTimeWaitSec="0" MaxTimeWaitAction="0" UseFillers="False" FillersSource="" FillersRecurse="True" FillerMaxAmount="120" Id="BBTHCRXFCOENENGPGOFG" Days="1111111" Weeks="00000" Time="2018-03-13 00:00:00" DelTaskTime="2018-03-13 00:00:00" />

</Events>

getlastplayed

получить список послежних проигранных треков

Параметры

"filter" = 1 - (необязательно) не включать треки, названия которых не были отправлены на сервер

Возвращаемые данные: XML, содержащий информацию о недавно проигранных треках. Показать пример

<?xml version="1.0" encoding="utf-8"?>

<LastPlayed>

  <TRACK ARTIST="Metallica" TITLE="Master Of Puppets" ALBUM="Master Of Puppets" YEAR="1986" GENRE="Metal" COMMENT="" FILENAME="D:\Metallica\Master of Puppets\02 Master Of Puppets.m4a" DURATION="08:35" PLAYCOUNT="1" LASTPLAYED="2018-01-16 20:20:38" INTRO="0.00" OUTRO="0.00" LANGUAGE="" F1="" F2="" F3="" F4="" F5="" STARTTIME="2018-01-16 20:20:38" />

  <TRACK ARTIST="Metallica" TITLE="Battery" ALBUM="Master Of Puppets" YEAR="1986" GENRE="Metal" COMMENT="" FILENAME="D:\Metallica\Master of Puppets\01 Battery.m4a" DURATION="05:12" PLAYCOUNT="1" LASTPLAYED="2018-01-16 20:20:30" INTRO="0.00" OUTRO="0.00" LANGUAGE="" F1="" F2="" F3="" F4="" F5="" STARTTIME="2018-01-16 20:20:30" />

</LastPlayed>

readtag

читать тег для файла

Параметры

"fn" - имя файла

Пример

http://127.0.0.1:9001/?pass=WxPe2JXh&action=readtag&fn=D:\Metallica\Metallica%20-%20Darkness.mp3

Пример возвращаемых данных: показать

<?xml version="1.0" encoding="utf-8"?>

<TagInfo>

  <File FN="D:\Metallica\Metallica - Darkness.mp3" Duration="446028" Artist="Metallica" Title="Darkness" Album="" Year="" Genre="" Comment="" BPM="" Rating="0" Playcount="0" />

</TagInfo>

writetag

изменить тег файла

Параметры

"fn" - имя файла

"data" - данные тега в формате XML (в формате, возвращаемом readtag)

Результат

OK в случае успеха

Error с описанием ошибки если сохранение прошло с ошибкой


Контроль доступа для пользователей

Функция RadioBOSS Контроль доступа для пользователей позволяет управлять доступом пользователей программы к различным функциям, например, Правка плейлиста; Добавлять, изменять и удалять вкладки; Контроль воспроизведения; Изменение настроек эффектов и др. Данная функция доступна только в версии RadioBOSS Advanced.

Функция Заблокировать: при нажатии данной опции у вас появится окно, которое заблокирует программу до тех пор, пока не будет введен пароль или не будет изменен пользователь:

Все опции в функции Пользователи очень легко настраиваются. Изменить настройки пользователей можно только введя пароль администратора.

Установка опции "Администратор (полный доступ)" автоматически дает все разрешения.

Настройка Default user указывает пользователя по умолчанию, с правами которого программа будет запускаться.

Если у вас установлена опция "Пользователи должны ввести пароль для входа в RadioBOSS", то при запуске программы нужно будет ввести пароль одного из пользователей.

ВНИМАНИЕ! Будьте внимательны при установке пароля для администратора. Если пароль будет утерян, то можно потерять доступ к программе. Первый пользователь в списке всегда имеет права администратора. Если созданы другие пользователи с правами администратора, они не могут удалить первого администратора, изменить или просмотреть его пароль.


Очередь воспроизведения

Очередь треков на воспроизведение в плейлисте может быть изменена, используя функцию Поставить в очередь. Это позволит менять очередь треков без перетаскивания их в плейлисте.

·Чтобы добавить трек в очередь на воспроизведение, нажмите на трек в плейлисте правой кнопкой мыши и выберите Поставить в очередь.

·Чтобы убрать трек из очередь на воспроизведение, нажмите на трек в плейлисте правой кнопкой мыши и выберите Удалить из очереди (эта команда доступна только для треков, стоящих в очереди).

·Просмотр и редактирование списка треков: в главном меню RadioBOSS нажмите Вид - Очередь воспроизведения...

Треки, поставленные в очередь будут отмечены номером по порядку воспроизведения в скобках.

Окно просмотра и редактирования списка треков, поставленных в очередь:


Автоматическое объявление времени

Программа RadioBOSS умеет автоматически объявлять текущее время.

Объявление времени добавляется через меню: Плейлист -> Объявление текущего времени

В этом диалоговом окне выберите папку, содержащую голосовые файлы. В папке должно быть 24 файла для объявления часа и 60 файлов для объявления минут.

Названия файлов:

·Файлы часа. Имя файла часа должно содержать латинскую букву «h» и двухзначное число, соответствующее часу. Например, файл hr_05.mp3 может содержать объявление «пять часов» (затем будет воспроизведен файл минут). Файлы часа с латинской буквой «o» в конце названия файла используются для объявления целого часа. Например, файл hr_05o.mp3 может содержать объявление «пять часов ровно» (объявлять минуты в этом случае нет необходимости).

·Файлы минут. Имя файла минут должно содержать латинскую букву «m» и двухзначное число, соответствующее минутам. Например, файл m_56.mp3 может содержать объявление «пятьдесят шесть минут».

Образцы голосовых файлов можно скачать с нашего сайта: http://www.djsoft.net/enu/download.htm

Объявление времени можно запускать при помощи Планировщика. Для этого щелкните по кнопке вызова мастера и выберите «Автоматическое объявление», после чего следуйте подсказкам.


Автоматическое объявление погоды

Автоматическое объявление погоды.

Обновление данных о погоде.

Чтобы обновить данные о погоде используйте планировщик с командой о погоде, например:

weather Moscow, RU

weather Krasnodar, RU

(Рекомендуется установить запуск данного события один или два раза в день для получения достоверной информации о погоде).

Данные о погоде обновляются, используя сервис OpenWeatherMap: http://openweathermap.org/

Переменные с данными о погоде:

Погода на сегодня

?temp | температура (градус Цельсия)
?temp_f | температура (градус по Фаренгейту)
?wind_speed | скорость ветра (м/с)
?wind_name | описание ветра (например, "Легкий бриз")
?humidity | влажность (процент)

Погода на завтра (значения такие же, только добавляется "_tom")

?temp_tom

?temp_tom_f

?wind_speed_tom

?wind_name_tom

?humidity_tom

Автоматическое объявление погоды с помощью Синтезатора голоса (чтобы добавить синтезатор голоса в меню нажмите Плейлист -> Дополнительно -> Добавить синтезатор голоса...)

Пример фразы:

Сегодня температура ?temp градусов Цельсия, скорость ветра ?wind_speed м/с, ?wind_name, влажность ?humidity процентов. Температура на завтра ?temp_tom градусов Цельсия, скорость ветра

?wind_speed_tom м/с, ?wind_name_tom, влажность ?humidity_tom процентов.

Если вы используете встроенный голос в Windows, лучшие результаты достигаются в Windows 8 и более поздних версиях. Встроенные голоса в Windows 7 и более ранних версиях голоса автоматического объявления звучат не очень хорошо (если вы не установите пользовательский голос).

Автоматическое объявление погоды с помощью предварительно записанных файлов о температуре и влажности

Названия файлов о температуре и влажности должны содержать числовое значение, например:

"TMP29.mp3" - температура "29 градусов Цельсия".

"TMP-10.mp3" - "-10 градусов Цельсия"

"HUM3.mp3" - "влажность 3%"

Создание плейлиста с соответствующей последовательностью треков, например, 3 треков:

1. Введение "Погода"

2. Температура на сегодня (добавьте один файл про температуру в плейлист)

3. Влажность (добавьте один файл про влажность в плейлист)

Сохраните плейлист в файл, например: weather.m3u8

Откройте плейлист в текстовом редакторе (вы можете использовать вкладку Блокнот в RadioBOSS, чтобы редактировать текст), файл должен выглядеть так:

#EXTM3U

#EXTINF:5,INTRO

C:\Weather\WeatherToday.MP3

#EXTINF:2,TMP7

C:\Weather\Temp\TMP7.MP3

#EXTINF:2,HUM5

C:\WeatherAnn\Hum\HUM5.MP3

Измените числовое значение переменных и сохраните файл:

#EXTM3U

#EXTINF:5,INTRO

C:\Weather\WeatherToday.MP3

#EXTINF:2,TMP007

C:\Weather\Temp\TMP?temp.MP3

#EXTINF:2,HUM005

C:\WeatherAnn\Hum\HUM?humidity.MP3

Установив задание в планировщик, погода будет воспроизведена автоматическим объявлением погоды, RadioBOSS заменит переменные на соотвествующие значения, например, ?temp станет "20" и имя файла C:\Weather\Temp\TMP?temp.MP3 будет конвертировано в C:\Weather\Temp\TMP20.MP3


Система запроса песен

Система запроса песен состоит из:

· Команды API для управления списком запросов.

·Окно со списком запрошенных песен - его можно открыть через меню Вид->Запросы песен (или нажав Ctrl+Y)

· Команда планировщика для автоматического воспроизведения запрошенных песен


Конвертер, CD граббер

В программе RadioBOSS есть возможность конвертации звуковых файлов в различные форматы.

Чтобы сконвертировать файл:

1. Выделите трек (или несколько треков) в плейлисте и нажмите правую кнопку мыши.

2. В появившемся меню, нажмите Дополнительно - Конвертировать...

Появится окно с параметрами конвертации. В нем можно указать, в какой формат нужно сконвертировать файл, в какую папку сохранить и другие настройки.

3. Установите необходимые параметры и нажмите ОК.

Будет запущен процесс конвертации:

После того, как он завершен, сконвертированные файлы можно найти в указанной папке.


DSP менеджер

Программа RadioBOSS позволяет использовать DSP-плагины VST и WinAmp (dsp_*.dll), кроме тех, которые изменяют скорость потока. Также можно использовать интегрированные DSP, такие как Equalizer и Compressor.

Чтобы открыть DSP менеджер, выберите вкладку «эффекты» на панели управления:

Для добавления DSP щелкните по кнопке «+», а для удаления — по кнопке «–». Для изменения параметров DSP воспользуйтесь кнопкой настройки [image] .

Для перемещения DSP вверх или вниз в списке щелкните по соответствующей стрелке. DSP применяются в порядке расположения, сверху вниз.

При щелчке по кнопке «+» будут показаны все доступные эффекты DSP:

Пометьте галочкой опции «DSP-плагины Winamp» и (или) «Плагины VST», если собираетесь использовать соответствующие плагины. Чтобы открыть папку, где программа RadioBOSS хранит DSP-плагины Winamp, нажмите кнопку «Папки плагинов...».

Выберите нужный плагин и щелкните OK. Плагин будет добавлен в список DSP:

Для включения или отключения эффектов DSP, соответственно, поставьте или снимите галочку в нужных местах.

Чтобы установить плагин WinAmp, сделайте следующее:

1. Скачайте и установите нужный плагин.

2. Откройте папку, в которую был установлен плагин (обычно это «C:\Program files\Winamp\Plugins»). Скопируйте оттуда файлы, относящиеся к плагину, в папку, в которой программа RadioBOSS хранит DSP-плагины Winamp (<RadioBOSS_Dir>\Plugins).

3. После установки плагинов включите опцию «плагины Winamp» на вкладке плагинов. После этого все найденные плагины Winamp должны появиться в списке.

Выберите нужный плагин и запустите его, щелкнув по кнопке «ОК».


Кеширование тегов

Кеширование информации о тегах и длительности позволяет существенно увеличить скорость обработки треков (чтение тегов и длительность). Использование кеширования уменьшит время генерации плейлистов, добавления добивок и прочих задач, где происходит чтение и/или определение длительности треков. Это также существенно увеличвает производительность если треки хранятся на сетевом диске (например, NAS) так как не требуется чтение файлов по сети.

Включить кеширование тегов вы можете в настройках на вкладке Общие. Установите Хранение дополнительной информации о треке в Базу данных и поставьте галочку Кешировать теги. Нажмите ОК. Для активации кеширования RadioBOSS необходимо перезапустить.

Кеширование имеет несколько ограничений, например, треки должны оставаться в одних и тех же папках и не должны переименовываться. Более подробная информация в разделе о плюсах и минусах хранения информации в базе данных SQLite.


Генератор DTMF тонов

Генератор DTMF тонов в RadioBOSS позволяет вставлять тоны DTMF в аудио поток. Поддерживаются стандартные символы DTMF: 0 - 9, A, B, C, D, # и *.

Чтобы добавить генератор тонов в плейлист нажмите в меню Плейлист - Дополнительно - Генератор DTMF тонов. Введите последовательность, например, "76AC" и нажмите OK. В плейлист будет добавлен специальный трек, который при запуске проиграет DTMF последовательность.

Можно также создать задание, которое проиграет DTMF тон: создайте задание и используйте команду dtmf=последовательность, например, dtmf=76AC.


Переменные для форматирования строки названия трека

Переменные, которые используются для форматирования строки названия трека или для уведомлений:

%artist - исполнитель трека

%title - название трека

%casttitle - название трека в плейлисте (только в уведомлениях)

%album - название альбома

%year - год

%comment - комментарий

%genre - жанр трека

%len - длительность трека (mm:ss)

%seconds - длительность трека в секундах

%filename - название файла без указания пути

%path - путь к файлу

%playcount - количество запусков

%listeners - количество слушателей (в текущий момент)

%showname - название программы или шоу в текущее время (установите, используя команду set %showname=TEXT)

Строка названия формата может включать любое количество переменных, указанных выше, вместе с любыми текстами и символами.


Хранение дополнительной информации

Дополнительная информация - это различные данные о треке, которые использует RadioBOSS в своей работе. Эта информация включает: количество запусков, дата последнего воспроизведения, дополнительные свойства трека (жанр, язык, BPM и др.), пользовательские поля тега и другая информация.

Существует два способа хранения дополнительной информации:

·Тег файла (APEv2) - по умолчанию

·База данных (SQLite)

Оба способа имеют свои достоинства и недостатки. Для обоих методов хранения информации настройка не требуется. Выбрать нужный вам способ вы можете в настройках. Вы всегда можете переключить способ хранения: Музыкальная база позволяет конвертировать информацию о треке с одного способа на другой, используйте опцию Сервис->Конвертация доп. информации.

Хранение информации в теге файла APEv2

Достоинства

oИнформация является постоянной, так как она хранится в файле: когда вы копируете или перемещаете файл, информация остается

oНе создаются дополнительные файлы

Недостатки

oФайл модифицируется при каждом воспроизведении (для обновления количества запусков и другой информации)

oНе все музыкальные файлы поддерживают APEv2, в этом случае для сохранения данных используются альтернативные потоки NTFS

oТребуется доступ на запись к музыкальным файлам, который не всегда возможен/желателен, особенно при использовании сетевого хранения информации

Хранение информации в базе данных SQLite

Достоинства

oМузыкальные файлы не модифицируются, потому что информация хранится отдельно

oИнформация может быть использована только для чтения музыкальных папок, например, сетевые папки доступны только для NAS чтения

oВыше скорость работы: загрузка информации с базы данных быстрее, чем чтение тега файла

Недостатки

oИнформация привязана к треку: если файл перемещать или переименовывать, дополнительная информация будет потеряна


Общие

Для настройки общих параметров программы:

В меню нажмите Настройки -> Настройки.

Выберите категорию Общие.

Параметры раздела Общие:

Запускать с Windows | Программа будет автоматически запускаться вместе с Windows. В окне Опции запуска вы можете установить задержку запуска программы и некоторые другие настройки.
Перезапуск программы в случае зависания | В случае зависания или критической ошибки программа будет автоматически перезапущена. Воспроизведение продолжится с того же места, где прервалось.
Спрашивать при закрытии | При закрытии программы нужно будет дать подтверждение.
Запустить плейлист | При запуске программы сразу начнется воспроизведение плейлиста.
Возобновить проигрывание | При запуске программы воспроизведение продолжится с того же места.
Кнопка на панели задач | Показывать ли кнопку программы RadioBOSS на панели задач.
Сортировка плейлиста кликом по колонке | При нажатии на заголовок колонки плейлиста он будет отсортирован.
Сортировка списка расписания кликом по колонке | Сортировка списка расписания кликом по колонке.
Хранение дополнительной информации о треке | Установите местоположение хранения дополнительной информации о треке (количество запусков, последнее воспроизведение, дополнительные поля тегов, ...). Варианты: ·Тег в файле (APEv2) - по умолчанию ·База данных (SQLite) Более подробная информация здесь.
Кеш тегов файла | Включить кеширование информации о теге и длительности. Это позволит ускорить процесс добавления треков в плейлист, генерацию плейлиста, добавление добивок, построение музыкальной базы и др. Это опция доступна только если "Хранение дополнительной информации о треке" установлено в базе данных.
Запоминать имена файлов плейлистов | Включите эту опцию, если нужно запоминать имена файлов плейлистов для вкладок.
Не удалять треки расписания из плейлиста при закрытии | При закрытии программы не будут удаляться треки расписания из плейлиста.
Удалять команды "stop" после исполнения | Команды "stop" будут удаляться из плейлиста после исполнения.
Рабочая папка Music library | Папка, где будут храниться файлы музыкальной базы. Базы из этой папки появятся в списке поиска и эта папка будет папкой по умолчанию при сохранении и загрузке муз. базы.
Папка для голосовых треков | Папка где будут сохраняться голосовые треки. Только треки из этой папки будут восприняты программой как голосовые треки (выделены курсивом в плейлисте).
Приоритет | Устанавливается уровень приоритета программы в системе. Чем выше, тем меньше вероятность "заикания" звука. Для стабильной работы рекомендуется High. Не рекомендуется Real-Time (наивысший), т.к. это может плохо сказаться на стабильности системы.
Действие кнопки "Х" | Действие, которое будет совершаться по нажатию на "крестик" в заголовке окна. Варианты: свернуть, закрыть.
Шкала громкости | Устанавливает тип шкалы громкости, все регуляторы громкости в программе, в т.ч. и кроссфейд будут использовать этот тип шкалы.


Типы файлов

Для настройки типов файлов:

В меню нажмите Настройки -> Настройки.

Выберите категорию Типы файлов.

Подробная информация: Использование различных типов файлов


Воспроизведение

Конфигурация устройств воспроизведения

Для настройки параметров воспроизведения:

В меню нажмите Настройки -> Настройки.

Выберите категорию Воспроизведение.

Основная карта | На это устройство будет воспроизводиться плейлист. Рекомендуется использовать ASIO если поддерживается картой или WASAPI.
Монитор | Дублировать сигнал основной карты на это устройство Предупреждение: не устанавливайте одну и ту же звуковую карту для основной карты и монитора, так как это повлечет за собой проблемы со звуком, такие как эхо.
Джинглы | Устройство, на которое будут воспроизводиться джинглы. Опция "Основная карта" устанавливает, что воспроизведение будет делаться на основной карте.
Карт-машина | Устройство для карт-машины Опция "Основная карта" устанавливает, что воспроизведение будет делаться на основной карте.
Предпрослушка (PFL) | Прослушка используется в плейлисте (значок в плейлисте или нажатием правой кнопкой мыши на треке), а также в TrackTool, редакторе кроссфейдов и записи голосовых треков.
AUX 1 AUX 2 | Звуковое устройство, которое может быть использовано в AUX плеерах
Если ничего не играет выводить тишину | Выводить тишину, если ничего не играет

Нажатие на одну из кнопок Изменить вызывает окно настроек карты:

В этом окне настраиваются параметры карты:

Драйвер

Используемый драйвер для доступа к карте

Рекомендации:

1) если карта поддерживает ASIO то ркомендуется использовать этот режим, это позволяет сократить задержку звука до минимума

2) если используется ОС Windows Vista, 7 или 8 - используйте WASAPI. Опция недоступна для Windows XP или более ранних версий.

3) используйте DirectSound если невозможно использовать первые две опции

Можно использовать программу на компьютере без звуковой карты - выберите No Sound. В этом случае программа будет кодировать поток и передавать его на сервер.

Устройство

Выбирается звуковая карта. Это может быть карта, установленная в системе, или виртуальная карта.

Настройки

Настройка карты:

Частота - частота дискретизации, 48000 по умолчанию

Размер буфера - размер буфера воспроизведения. 50 мс рекомендуется для WASAPI, 500 мс для DirectSound. ASIO использует настройки драйвера карты.

Каналы (только ASIO) - на какие каналы карты выводить звук

Канал - указывается, на какую пару колонок выводить звук. В панели управления Windows нужно установить многоканальный режим работы.

Эксклюзивно - использовать карту в эксклюзивном режиме (не рекомендуется).

Event-driven - использовать буферизацию, основанную на системе событий. Для некоторых звуковых карт нужно включить эту опцию для решения проблем воспроизведения.


Разное

Дополнительные настройки воспроизведения.

Обрезать тишину в начале и конце файла | Если отмечено, то программа автоматически уберет тишину в начале и конце трека. Настройка чувствительности задается в дБ, все что ниже заданного уровня - считается тишиной
ReplayGain | Показывает как тег ReplayGain может быть обработан
Уровень Mute | Уровень в дБ, на который понизится громкость при приглушении (кнопка Mute на панели инструментов).
Прокси для воспроизведения интернет-потоков | Укажите прокси сервер, который будет использоваться при воспроизведении URL
ФНЧ и ФВЧ | Фильтры нижних и высоких частот
Предупреждать о конце трека | Опция позволит вам контролировать обратный отсчет, указанный под треком в эфире, который будет мигать красным за установленное количество секунд до окончания трека
Исключить треки короче... | Вы можете исключить треки короче заданной длительности, которые будут обозначаться красным миганием при обратном отсчете


Фейды

Настройки фейдов, карт-машины и голосовых треков.

Время Fade in/out при запуске поверх эфира | Плавное изменение громкости эфира в течение указанного времени при запуске трека поверх эфира (джингл или трек из расписания с опцией "запускать поверх эфира").
Отключить затухание для треков если плейлист в ручном режиме | Если нажата кнопка "Остановка после этого трека", музыка не будет затухать (fade out)
Выключить кроссфейд для коротких треков | Кроссфейд не будет применяться для треков короче 45 секунд
Фейд при остановке трека | Плавное затухание звука происходит при нажатии кнопки "Стоп". Если опция включена, то остановить трек без фейда можно дважды нажав на кнопку "Стоп"
Карт-машина | Настройки воспроизведения карт-машины
Голосовые треки | Настройки воспроизведения для голосовых треков


Микрофон/лин. вход

Программа RadioBOSS позволяет задать настройки микрофона и линейного входа. Эти настройки будут использованы при воспроизведении звука с линейного входа (файл LINE.IN) для кнопки MIC и обнаружения сигнала DTMF.

Настройка параметров микрофона и линейного входа:

Выберите в меню следующее: Настройки -> Настройки.

Выберите категорию Микрофон/Лин. вход.

Кнопка MIC

Кнопка MIC находится в правом нижнем углу главного окна. Далее приводятся инструкции по настройке этой кнопки.

Нажмите Изменить... для выбора драйвера (DirectSound/WASAPI/ASIO/Windows Mixer) и устройства.

Внимание! Не рекомендуется использовать «Windows mixer control», так как в этом случае звук не будет обрабатываться с помощью RadioBOSS, что накладывает некоторые ограничения.

Уровень музыки — уровень громкости плейлиста во время использования микрофона, свойством Фейд можно контролировать плавность изменения громкости. Уровень -50дБ и ниже полностью выключает музыку.

Усилитель микрофона — увеличить уровень микрофона при необходимости. Щелкнув по кнопке «Тест», можно проверить работу микрофона.

Выводить только на сервера вещания — если включить эту опцию, звук микрофона будет выводиться только на серверы вещания. Если у вас активирована эта опция, то рекомендуется в настройках воспроизведения включить опцию "Если ничего не играет, выводить тишину".

Push-to-Talk — включить режим PTT. В этом случае нужно удерживать кнопку MIC.

Активация голосом - при включении данной опции активация микрофона будет происходить автоматически, когда говорят в микрофон.

Кнопка DSP позволяет назначить эффекты для микрофона.

Эффекты для микрофона также можно назначить правым кликом по кнопке MIC. Нельзя использовать те же Winamp DSP плагины, что и для эфира.

Вход 1 (Line.in), Вход 2 (Line2.in)

Выбор устройства для входов LINE.IN.

Дополнительно:

Использование линейного входа

Использование микрофона


Вид

Настройки внешнего вида программы и формата вывода некоторых данных.

Для настройки вида программы:

В меню нажмите Настройки -> Настройки.

Выберите категорию Вид.

Формат названия трека | Устанавливает формат названия трека в плейлисте. Пример: %artist - %title - %album Выведет через тире название, исполнителя и альбом Возможные значения указаны здесь
Колонка "имя файла" | Режим отображения имени файла
Расстояние между треками в плейлисте | Устанавливает расстояние между треками в плейлисте
Сетка в плейлисте | Показывать сетку в плейлисте
Только горизонтальные линии | Если включена сетка в плейлисте, показывать только горизонтальные линии
Подсвечивать трек под указателем мыши | Выделяет трек под указателем мыши
Цвет выделения | Устанавливает фон и шрифт текущего трека
Расстояние между элементами в поиске | Устанавливает расстояние между элементами в поиске
Показывать название потока | В случае, когда запущен интернет-поток, в зависимости от этой опции: включена: будет выводиться название трека и название станции выключена: будет выводиться только название трека
Прятать URL потока при воспроизведении | Скрывает URL потока при воспроизведении
Формат часов | Возможно принудительно установить 24-часовой формат
Изменение часовой зоны | Изменить часовую зону для программы
Показывать температуру и влажность в главном окне | Температура и влажность будут указываться в главном окне программы
Визуализация | Стиль визуализации в окне "В эфире"
Выключить визуализацию/отображение уровня | Включите эту опцию для снижения загрузки на процессор

В разделе Стиль вы можете изменить внешний вид программы.


Стиль

Для настройки стиля программы:

В меню нажмите Настройки -> Настройки.

Выберите категорию Стиль.

В этом разделе можно изменить внешний вид интерфейса программы. Можно выбрать из уже готовых стилей из списка Стиль.

Можно также изменить параметры стиля: шрифт окон и плейлиста, настройки цветов, стиль кнопок и т.д.


Детектор тишины

Детектор тишины служит для обнаружения тишины в эфире. Например, в случае какой-либо ошибки. При наступлении тишины можно выполнять какое-либо действие.

На этой закладке устанавливается время тишины, после которого срабатывает детектор, а также задается действие при обнаружении тишины. "Тишина" определяется по уровню сигнала, если уровень ниже установленного (по умолчанию -70дБ) - это считается тишиной.

Чтобы установить Детектор тишины:

1. В главном меню нажмите Настройки -> Настройки... или в панели инструментов нажмите Настройки.

2. Выберите категорию Детектор тишины.

3. Чтобы установить интервал тишины передвигайте ползунок. Например, если вы установите интервал 10 сек, то после 10 сек Детектор тишины начнет действие.

4. Следующим шагом вы выбираете действие для Детектора, которое он должен совершить при обнаружении тишины. Это может быть запуск следующего трека, запуск плейлиста с начала или запуск аварийного плейлиста.

5. Чтобы активировать функцию Детектор тишины, включите галочку.

6. Нажмите OK.

Больше информации:

Воспроизведение


Вещание

Для настройки вещания в интернет:

В меню нажмите Настройки -> Настройки.

Выберите категорию Вещание.

Для подробной информации см. раздел Вещание в интернет.

Кнопка Дополнительно позволит настроить дополнительные настройки.

Прокси-сервер - укажите прокси-сервер для вещания. Оставьте поле пустым, если вы не знаете, для чего это нужно. Неправильно настроенный прокси-сервер будет блокировать любые попытки соединения и трансляция не будет работать. Важно! Прокси сервер должен поддерживать метод HTTP "CONNECT".

Custom encoders - опция позволяет добавить любые пользовательские кодировщики. RadioBOSS может использовать любые кодировщики, которые поддерживают ввод/вывод через консоль.

Команда кодировщика может включать следующие переменные (значения соответствуют настройкам кодировщика в RadioBOSS):

{SampleRate} - частота дискретизации в Гц (например, 44100)

{KSampleRate} - частота дискретизации в кГц (например, 44.1)

{Bitrate} - битрейт в кбит (например, 128)

{Channels} - количество каналов (например, 2)

Кодировщику нужно сообщить (через командную строку) что входные данные будут направлены в STDIN, и что нужно направить вывод в STDOUT.

MIME тип зависит от формата файла кодировщика.

RadioBOSS отправляет PCM данные в кодировщик в формате: 16 бит целочисленные со знаком, Little-Endian.

Пример командной строки для MP3 кодировщика lame.exe

path_to_lame\lame.exe -r -s {KSampleRate} -b {Bitrate} --resample {KSampleRate} - -

Пример командной строки для ffmpeg, кодирование в формате mp3

<path>\ffmpeg.exe -loglevel -8 -f s16le -ac {Channels} -ar {SampleRate} -i - -f mp3 -c:a libmp3lame -b:a {Bitrate}k -

Пример командной строки для вывода в несжатом RAW PCM. Кодировщик pcmraw.exe находится в папке Plugins, где установлена программа RadioBOSS (по умолчанию C:\Program Files (x86)\RadioBOSS)

C:\Program Files (x86)\RadioBOSS\Plugins\pcmraw.exe - -


Метаданные

Настроить информацию о станции вы можете в категории Метаданные:

В меню нажмите Настройки -> Настройки.

Выберите категорию Метаданные.

Информация о станции | Заполните информацию о вашей станции
Название трека | Устанавливается формат названия трека. Формат может включать несколько строк, которые будут сменять друг друга. При использовании нескольких строк вариант обновления названий должен быть задан "Периодически". Возможные значения смотрите здесь: Переменные для форматирования строки названия трека
Обновлять название | Когда RadioBOSS обновляет название трека на сервере. Возможные значения для обновления: ·Периодически - установите время в секундах для периодического обновления названия ·При запуске трека - название трека будет обновляться при запуске трека


Отчеты

В программе RadioBOSS есть возможность вести отчет о всех проигранных треках, а также о других событиях (запуск/закрытие программы, запуск заданий планировщика, ошибки). Также можно передавать информацию на сайт или в любое другое место с помощью функций экспорта, запроса HTTP и загрузки файла по FTP. К таким функциям относятся : исполнитель, название, продолжительность, жанр, альбом и другая информация. Можно также настроить отправку уведомлений для различных заданий, таких как ошибки, e-mail адрес.

Для настройки отчетов:

1. В меню нажмите Настройки->Настройки.

2. Выберите категорию Отчеты.

По умолчанию отчетная функция активирована. Вы можете настроить программу так, чтобы номер дорожки входил в отчет и изменить папку для сохранения отчетов.

Вы можете также настроить программу так, чтобы сохранять название дорожки, которая воспроизводится (nowplaying.txt) в файл и загружать его на сервер FTP. В файл сохраняется название трека в формате, который задан в настройках Вид - Формат названия трека.

Опция Сохранять обложку включает сохранение обложки трека. Иллюстрации будут сохранены как изображения в формате PNG и изменены до максимального размера 400 пикселей. Если у трека нет обложки, то обложка не будет сохранена. Если нужно указать файл обложки для треков без обложки, создайте в папке настроек файл nocover.png (чтобы открыть папку с настройками, нажмите Настройки-Открыть папку с настройками в меню).

3. Для настройки параметров подключения FTP-сервера, щелкните Настройки FTP...".

Программа также позволяет использовать НТТР запрос для отправки информации текущей дорожки на определенный интернет адрес. Она также может отправлять вам уведомления о различных событиях, таких как подключение и отключение сервера, обнаруживать тишину, ошибки.

Также можно использовать HTTP запрос на сайт. Подробнее в этом разделе: HTTP запрос.

4. Нажмите OK.

Дополнительно

Вещание в интернет


Уведомления

HTTP запрос используется для отправки информации о проигрываемом треке на сайт. Может использоваться дл того, чтобы показывать название трека на сайте, вести историю и т.п.

Для использования HTTP запроса:

1. В разделе Отчеты в настройках включите "Использовать HTTP запрос". Если вы планируете использовать E-mail уведомления, щелкните "Настройки e-mail..." и заполните SMTP-сервер электронной почты.

2. Нажмите [+] для добавления HTTP запроса (количество запросов может быть любым).

3. Появится окно с параметрами HTTP запроса.

Введите URL (http://) к скрипту на сайте и параметры вызова.

HTTP уведомления

Для уведомлений "Воспроизведения списка треков", вы должны заполнить поле URL-адрес, с необходимыми параметрами, например: http://example.com/updatesonginfo.php?artist=%artist&title=%title

Кодировка зависит от того, что ваш сценарий принимает. UTF8 в большинстве случаев работает и не имеет проблем с международными символами.

Значения, которые можно использовать в HTTP запросе: Переменные для форматирования строки названия трека

Для других типов уведомлений, используйте следующие параметры:

%msgtype - тип сообщения: server для сообщений о подключении/отключении к серверу; silence для сообщений обнаружения тишины и error для уведомлений об ошибках

%msgtext - текст сообщения

Уведомления по E-mail

Чтобы отправить уведомление на адрес электронной почты, введите адрес в поле URL-адрес/e-mail поле. Может быть указано несколько адресов через запятую.

Используйте кнопку Мастер настройки для облегчения процесса настройки интеграции с Tune In и Twitter.


Видео

RadioBOSS может также воспроизводить и видео файлы. В этом окне можно настроить параметры воспроизведения видео.

Для настройки воспроизведения видео:

В меню нажмите Настройки -> Настройки.

Выберите категорию Видео.

Показывать видео окно при запуске видеофайла - при запуске видео трека появится окно с изображением. Если оно не нужно, эту опцию следует выключить.

Показывать видео на полный экран на мониторе - на выбранном мониторе видео будет проигрываться на полный экран. Чтобы выйти из полноэкранного режима нажмите клавиши Enter или F4.


Управление

Настройка функции двойного клика мыши в плейлисте, возможность скрыть некоторые элементы управления.

Для настройки элементов управления:

В меню нажмите Настройки- > Настройки.

Выберите категорию Управление.


DTMF

Настройка работы DTMF.

Для настройки детектора DTMF:

В меню нажмите Настройки -> Настройки.

Выберите категорию DTMF.

Поиск DTMF | Источник, где будут проверяться DTMF метки: линейный вход или интернет-поток.
Минимальный уровень DTMF | Минимальный уровень меток.
Время поиска DTMF | Указывается время, в течение которого RadioBOSS будет искать DTMF метки. Опции "до" и "после" связаны с событием начального времени.
Задержка срабатывания DTMF | Запуск события при обнаружении задержки срабатывания DTMF (секунд)

Для более подробной информации прочтите раздел Запуск заданий по метке DTMF


API

Настройка модуля удаленного управления программой.

Для настройки удаленного доступа:

В меню нажмите Настройки -> Настройки.

Выберите категорию API.

Включить удаленное управление | Включить или выключить удаленное управление
Порт | Порт, на котором будут приниматься команды
Пароль | Пароль для отправки команд. Убедитесь, что пароль достаточно надежен, для предотвращения несанкционированного доступа

Описание набора команд API размещено в разделе Remote Control API


Планировщик

Для настройки планировщика:

В меню нажмите Настройки -> Настройки.

Выберите категорию Планировщик.

Оповещать о запуске задания планировщика за - указывается количество секунд, в течение которого программа будет предупреждать о скором запуске задания планировщика. Предупреждение выводится в окне "Следующий трек" и в списке заданий планировщика.

Максимальное время для генерации плейлиста по расписанию - максимальное время, отведенное на генерацию плейлиста командой generate. Подробнее: Автоматическое создание плейлиста.

Не запускать задания, если плейлист стоит на паузе - если плейлист остановлен, задания запущены не будут.

Не запускать задания при включенном микрофоне - если включен микрофон, задания запущены не будут.

Выбор добивок: допустимое отклонение длительности (сек) - при выборе добивок до запланированного задания, длительность добивок может быть больше, чем задано.


Интерфейс

Интерфейс программы RadioBOSS:

1. Меню.

Меню позволяет использовать множество функций программы.

Подробная информация в разделе Меню

2. Панель инструментов.

Некоторые функции вынесены на панель инструментов для удобного доступа.

Подробная информация: Панель инструментов

3. Панель управления.

Содержит планировщик, проводник, поиск по базе и DSP эффекты.

Подробная информация: Панель управления

4. Плейлист (зона 1).

Окно плейлиста содержит список треков в виде таблицы.

Дополнительная информация: плейлист.

5. Зоны 2 и 3

Дополнительные зоны можно активировать через меню Вид - Рабочие зоны.

В зонах 2 и 3 можно разместить Карт-машину, AUX плейлист, Web браузер, Блокнот, Поиск и проводник.

Дополнительная рабочая зона выполнена в виде отдельного окна и может быть использована, например, на другом мониторе.

6. Плеер.

Управление воспроизведением:

Более подробную информацию об управлении воспроизведением вы можете посмотреть здесь: Управление воспроизведением.

Стиль кнопок плеера можно изменить, нажав: Настройки->Вид, далее выберите категорию Стиль.

Вы можете изменить логотип радио. Для этого нажмите правой кнопкой мыши на картинку в правом верхнем углу. У вас появится окно, в котором вы сможете выбрать новый логотип.

Над логотипом имеется надпись Default - это название текущего профиля. Изменить его можно, сохранив профиль под другим именем, нажав Настройки -> Сохранить профиль как.

Дополнительно:

Меню

Панель инструментов

Панель управления

Плейлист

Управление воспроизведением


Меню

Меню программы RadioBOSS

Описание разделов:

Файл | Открыть, сохранить, распечатать плейлист
Правка | Редактирование плейлиста
Вид | Изменение вида программы
Плейлист | Добавление треков и команд в плейлист
Инструменты | Инструменты: Музыкальная база, Генератор отчетов, Рекламный планировщик, Запись потока
Джинглы | Джинглы быстрого доступа
Настройки | Настройки программы и операции с профилем
Справка | Справка, ввод регистрационного кода


Файл

Пункты меню:

Создать | Создать плейлист
Открыть... | Открыть плейлист
Сохранить | Сохранить плейлист
Сохранить как... | Сохранить плейлист как
Экспорт/печать... | Печать плейлиста
Выход | Выход из программы


Правка

Пункты меню:

Отменить | Отменить последнюю операцию в плейлисте
Вырезать | Вырезать выделенные треки
Копировать | Копировать
Вставить | Вставить
Выделить все | Выделить все треки в плейлисте
Удалить кроме выделенных | Удалить все треки кроме выделенных
Удалить | Удалить выделенные треки
Удалить все | Очистить плейлист


Вид

Пункты меню:

Проводник | Показать проводник
Поиск | Показать поиск
Планировщик | Показать планировщик
Эффекты | Показать вкладку эффектов
Рабочие зоны | Установить количество рабочих зон. Вторая рабочая зона может быть использована для поиска, Web-браузера или карт-машины.
Информация о треке | Спрятать/показать панель информации о треке.
Левая часть | Спрятать/показать левую часть окна
Микрофон и уровень в центре | Спрятать/показать микрофон и уровень в центре
Строка состояния | Спрятать/показать строку состояния
Панель инструментов | Спрятать/показать панель инструментов
Верхняя панель | Полный размер/минимум/спрятать верхнюю панель
На весь экран | Сделать программу на весь экран
Цвета и шрифты... | Изменить цвет и шрифт плейлиста
Колонки плейлиста... | Придать форму колонкам плейлиста
Центровка плейлиста | Автоматически прокручивать плейлист до играющего трека
Выделять текущий трек | Выделять/не выделять текущий трек при воспроизведении
Текущий трек в окне информации | Если включено, при запуске трека окно информации будет содержать информацию о текущем треке
Режим Screen Reader | Включить/выключить режим Screen Reader
Language | Выбрать язык интерфейса


Плейлист

Добавление в плейлист различных элементов.

Пункты меню:

Playlist Generator Pro... | Открыть Playlist Generator Pro
Добавить файл... | Добавить трек в плейлист
Добавить папку... | Добавить треки из папки
Добавить URL... | Добавить интернет-поток
Добавить команду... | Добавить команду
Вставить паузу... | Вставить тишину нужной длительности
Добавить нарезки... | Добавить нарезку треков.
Объявление текущего времени... | Добавить Автоматическое объявление времени
Добавить линейный вход... | Добавить линейный вход в плейлист. Пункт меню появится в списке, если для линейного входа в настройках выбрано устройство
Вставить плейлист | Добавить плейлист. Плейлист появится в виде одной записи в плейлисте и будет раскрыт при воспроизведении
Добавить треки из плейлиста... | Вставить треки из плейлиста
Вставить голосовой трек... | Вставить в плейлист голосовой трек
Записать голосовой трек... | Открыть программу для записи голосовых треков.
Добавить Track List... | Добавить Track List
Защита от повторов Track List... | Настройки правил неповторения для Track List
Блокнот... (Т) | Открыть блокнот. Нажмите правой кнопкой мыши на окне блокнота чтобы изменить режим его работы (запись для одного трека или общая запись).
Поиск... | Найти трек в плейлисте
Дополнительно
Добавить синтезатор голоса | Добавить текст для автоматического объявления. Можно указать текст, который должна проиграть программа, или путь к файлу с текстом. Файл может содержать XML теги согласно Speech API: https://msdn.microsoft.com/en-us/library/ms717077(v=vs.85).aspx
Добавить генератор DTMF тонов | Добавить генератор тонов DTMF.
Показать дубликаты | Выделить дубликаты треков в плейлисте
Копировать в папку... | Скопировать выделенные треки в папку. Если выделены все треки в плейлисте, то скопированные треки будут иметь цифру (порядковый номер трека) в имени файла. Это позволит сделать порядок треков в папке таким же, как и в плейлисте.
Удалить файлы с диска | Удалить файлы из плейлиста и с диска
Удалить несуществующие | Удалить из плейлиста файлы, которых нет на диске
Перемешать | Перемешать треки в плейлисте
Генератор плейлистов... | Запустить старую версию генератора плейлистов (используйте только если переходите со старой версии программы).

Дополнительно:

Генерация плейлиста

Использование микрофона

Использование линейного входа

Использование Track list

Голосовые треки


Инструменты

Запуск различных модулей: Музыкальная база, генератор отчетов и т.п.

Музыкальная база | Открыть музыкальную базу
Генератор отчетов | Открыть генератор отчетов
Менеджер рекламы | Открыть менеджер рекламы
Auto Intro | Открыть настройки Auto Intro
Статистика вещания... | Открыть окно со статистикой вещания в интернет
Очередь воспроизведения... | Открыть список очереди воспроизведения
Запросы песен... | Открыть окно с запросами песен
Очистить кеш тегов | Очистить кеш тегов
Запись потока | Запись эфира


Джинглы

Пункты меню:

1-9 | Список назначенных джинглов
Назначить... | Назначить джинглы

Джинглы, назначенные этой командой могут быть проиграны нажатием кнопок 1-9 на клавиатуре или нажатием соответствующих кнопок на панели инструментов.


Настройки

Пункты меню:

Сохранить профиль | Сохраняет текущий профиль настроек.
Сохранить профиль как... | Сохраняет текущий профиль настроек как...
Загрузить профиль | Загружает профиль настроек.
Сохранять профиль при выходе | Автоматически сохраняет профиль настроек при закрытии программы. Эта опция включена по умолчанию.
Периодически сохранять профиль | Периодически сохраняет профиль настроек. Можно задать периодичность сохранения.
Открыть папку с настройками | Открывает папку, в которой программа RadioBOSS хранит настройки и другие данные.
Открыть папку с отчетами | Открывает папку с отчетами. Отчет — это файл .csv с записями о работе программы (какие треки и когда воспроизводились, какие запланированные задания запускались и др.).
Резервная копия настроек | Создает резервную копию настроек (профиль, плейлисты, запланированные задания и др.) и сохраняет ее в один файл.
Горячие клавиши | Позволяет настроить горячие клавиши.
Кроссфейды | Позволяет настроить кроссфейды.
Настройки... | Открывает диалоговое окно «Настройки».


Справка

Пункты меню:

Содержание | Открыть документацию
С чего начать | Открыть документацию
Сайт в Интернет | Открыть официальный сайт программы
Форум пользователей | Открыть форум
Техподдержка | Отправить вопрос Отправить отчеты об ошибках
Проверить обновление | Проверить доступность новых обновлений
Ввести регистрационный код... | Открыть окно для ввода регистрационного ключа
О программе... | О программе...


Пользователь

Управление пользователями программы. Подробнее в разделе Контроль доступа для пользователей.


Панель управления

Панель управления позволяет переключиться в другой вид или режим.

Описание пиктограмм:

folder | Проводник — просмотр папок и файлов для добавления треков в плейлист (подробнее)
xmag | Поиск — мгновенный поиск трека по ключевому слову в названии композиции или альбома, имени исполнителя и др. (подробнее)
 | Планировщик — планировщик заданий (подробнее)
tune | Эффекты — настройка эквалайзера, музыкального темпа и др. (подробнее)


Проводник

Проводник позволяет просматривать папки и их содержимое.

Чтобы добавить трек в плейлист перетащите его с помощью мыши.

Поиск включается правым кликом мыши. Список может быть обновлен вручную кнопкой F1.


Поиск

Поиск позволяет найти трек в музыкальной базе или папке (нажмите на стрелку справа, чтобы выбрать источник поиска). При поиске в папке, поиск идет в указанной папке и в ее подпапках.

Поиск производится автоматически по мере ввода символов в поле Поиск.

В качестве ключевого слова вводится первая буква, и программа автоматически запрашивает его в базе данных, и выводит список всех треков, соответствующие запросу. Результаты сужаются по мере ввода текста пользователем. Пользователи могут выполнять поиск ключевых слов в названиях, исполнителях, альбомах, годах, жанрах, комментариях и др.

Для добавления найденных треков в плейлист можно использовать горячие клавиши:

Num+ или Insert добавить после текущего трека

Num- добавить в конец плейлиста

Нажмите правой кнопкой мыши на кнопку "Стоп" для просмотра содержимого всей базы в результатах поиска.

Вы можете прослушать трек вне эфира через поиск. Для этого нажмите Alt+ кнопкой мыши по треку (или нажмите Alt+R).

Дополнительно:

Музыкальная база


Планировщик

Планировщик позволяет запустить трек, плейлист или выполнить действие в заданное время.

Назначение кнопок:

Вкл | Включить и выключить планировщик. Неактивная (серая) опция означает, что планировщик был отключен командой «scheduler off».
Ручной режим | Ручной режим работы планировщика: задания не будут запускаться автоматически; для запуска задания следует выделить его в списке и щелкнуть по кнопке «Запустить».
Запустить | Принудительно запустить выделенное задание
Добавить... | Добавить задание
Изменить... | Редактировать задание
Удалить | Удалить задание
Список | Работа со списком
Сохранить | Сохранить список заданий в файл (.sdl)
Загрузить | Загрузить задания из файла (.sdl)
Печать | Печать списка заданий
Импорт | Добавить задания в список из выбранного файла (.sdl)
Очистить | Удалить все задания

Колонки в списке:

Запустится через | Оставшееся время до запуска запланированного задания
Дата | Дата запуска запланированного задания (опционально)
Время | Время запланированного запуска
Сразу | Статус опции «Запустить сразу» («+» — включено, «–» — отключено)
Поверх | Статус опции «Воспроизвести поверх эфира» («+» — включено, «–» — трек будет включен в основной плейлист)
Уровень отключения | Уровень громкости плейлиста при выполнении задания с включенной опцией «Воспроизвести поверх эфира»
Файл | Имя файла и путь к файлу в имени файла или команде
Имя | Название задания

Дополнительно

Планировщик


Эффекты

На вкладке Эффекты можно видеть текущий уровень сигнала, контролировать его, а также добавлять эффекты.

Для добавления эффекта нажмите кнопку "+", для удаления кнопку "-".

Кнопка со значком инструментов - конфигурация выделенного эффекта.

Можно использовать встроенные эффекты: эквалайзер, компрессор, а также использовать плангины VST и Winamp.

Информация о статусе AutoAmp (автоматическое регулирование громкости) и отрезанной тишине в начале и конце трека. Нажатием на кнопки можно настроить эти функции.

Дополнительно:

Использование микрофона

DSP менеджер


Панель инструментов

Вид панели инструментов:

Назначение кнопок:

 | Создать плейлист
 | Открыть плейлист
 | Сохранить плейлист
 | Сохранить плейлист как...
 | Вырезать
 | Копировать
 | Вставить
 | Отменить последнюю операцию в плейлисте
 | Спрятать/показать левую часть
 | Рабочие зоны: 1
 | Рабочие зоны: 2
 | Рабочие зоны: 3
additional | Рабочие зоны: Дополнительная
add | Добавить трек
 | Добавить плейлист. Плейлист появится в виде одной записи в плейлисте и будет раскрыт при воспроизведении.
 | Вставить треки из плейлиста
 | Добавить треки из папки
 | Запись потока
statistics | Статистика
broadcasting | Вещание
 | Настройки
mute | Mute Monitor - заглушить звуковую карту (Монитор)


Плейлист

Окно плейлиста содержит список всех треков в текущем плейлисте, включая информацию о треке.

Чтобы настроить колонки плейлиста в главном меню нажмите Вид -> Колонки плейлиста...

Вы можете выполнять различные действия с треками, нажав на соответствующий значок в плейлисте:

pl1 | Прослушать трек
pl2 | Удалить трек
pl3 | Воспроизвести трек
pl4 | Добавить команду "стоп" после трека

Колонка Слушатели показывает текущее количество слушателей и изменение относительно предыдущего трека.

По умолчанию, есть два плейлиста. Можно создать любое количество плейлистов с помощью кнопки "+".

Нажав правой кнопкой мыши на плейлист, вы можете переименовать плейлист, удалить или совершить любое другое действие:

Удалить проигранные треки из плейлиста - если опция включена, треки будут удаляться из плейлиста после воспроизведения.

Если вы хотите запретить воспроизведение плейлиста, нажмите правой кнопкой мыши на вкладку плейлиста и включите опцию Запретить воспроизведение.

Сделать плейлист основным - опция отмечает плейлист в качестве активного плейлиста для воспроизведения. Задания планировщика вставляются в основной плейлист.

Треки обозначены синим значком ноты. Серый значок у проигранных треков. Треки со значком часов - запущены по расписанию.

Различные типы файлов (реклама, позывные станции, джинглы и т.п.) могут быть выделены цветом в плейлисте.

Можно перетаскивать файлы внутри плейлиста с помощью мыши или используя кнопки: Ctrl+Down, Ctrl+Up. Вы можете перетаскивать файлы между разными плейлистами (например, AUX плейлистами).

Вы можете ставить треки в очередь на воспроизведение. Для этого нажмите на трек правой кнопкой мыши -> Поставить в очередь. Рядом с номером трека в скобках вы увидите номер трека в очереди.

Под плейлистом находится раздел информации о треке, в котором вы можете редактировать теги.

Вы можете прослушать трек, для этого нажмите Alt кнопкой мыши по треку.

Вы можете устанавливать рейтинг и тип файла для каждого трека. Для этого нажмите правой кнопкой мыши по плейлисту и выберите пункт Дополнительно.

Тип файла вы можете установить как через плейлист, так и через музыкальную базу: выделите один или несколько треков, нажмите правой кнопкой мыши на трек в музыкальной базе и выберите Свойства трека.

В поле информации о треке показывается картинка выделенного трека. Для треков, у которых нет картинки можно поместить файл nocover.png в папку с настройками - эта картинка будет отображаться в поле Информация о треке для треков без обложки. Папка настроек открывается через меню Настройки -> Открыть папку с настройками.

Дополнительно:

Карт-машина

Типы файлов


AUX плееры

AUX плееры - это мини-плейлисты. Эти плееры могут быть использованы для различных целей: сохранения и редактирования плейлистов, воспроизведения треков, джинглов и т.п.

AUX плееры могут быть добавлены только в Зоне 2 или Зоне 3. В целях активизации этих зон используется команда меню: Вид->Рабочие Зоны->2 (или 3).

Возможно использование перетаскивания треков между обычными и AUX-плейлистами: просто начните перетаскивание трека за его значок (см. страницу Плейлист для подробностей).

По умолчанию, AUX плееры вопроизводят треки на основном звуковом устройстве. Также звук можно выводить на другое устройство. Нажмите на кнопку Настройка, чтобы выбрать устройство. Если для воспроизведения выбрано устройство AUX1 или AUX2, убедитесь, что эти устройства правильно сконфигурированы в настройках Воспроизведения.


Управление воспроизведением

Управление воспроизведением.

Стиль кнопок можно изменить в настройках в разделе Вид.

Изменить позицию проигрывания трека можно нажатием правой кнопкой мыши на окне "В эфире":

Назначение кнопок:

Перейти к предыдущему треку

Начать воспроизведение выделенного трека

Перейти к следующему треку

Пауза

Стоп

Включить повторение трека. Нажмите правой кнопкой мыши на кнопке чтобы выбрать дополнительные режимы работы.

Не переходить автоматически к следующему терку. Клик правой кнопкой мыши может изменить режим работы.

Воспроизведение в случайном порядке. Внимание! Если в плейлисте есть треки из планировщика, случайное воспроизведение работать не будет! (треки будут играть по порядку).

Включить повторение плейлиста

Изменение громкости

Вы можете изменить стиль кнопок: Настройки -> Вид.

Дополнительно:

Генератор плейлистов


Горячие клавиши

Чтобы открыть окно настроек горячих клавиш, нажмите Настройки -> Горячие клавиши.

Если вы хотите изменить какую-либо горячую клавишу, нажмите на обозначение клавиши и наберите удобные для вас символы.

Дополнительные горячие клавиши:

Ctrl+E запустить или остановить вещание в интернет.

Ctrl+Shift+Number (0..9) - установить рейтинг трека (1-9 - установить рейтинг от 1 до 9, 0 - установить рейтинг 10). Если Ctrl+Shift+0 не работает, нужно убрать привязку в панели управления Windows:

1. В панели управления выберите Языки.

2. Выберите Дополнительные параметры даты и времени.

3. Выберите Язык, затем слева Дополнительные параметры.

3. Нажмите "Изменить сочетания языковой панели".

4. В разделе "Переключение между языками" отмените назначение сочетания Ctrl+Shift+0.


Лицензия

End-User Licence Agreement for RadioBoss

ЛИЦЕНЗИОННОЕ СОГЛАШЕНИЕ RadioBOSS

Лицензия на использование и распространение (Далее программа - RadioBOSS, автор - DJSoft.Net (Кузьмицкий Дмитрий)

Программа распространяется по принципу "попробуй перед тем, как купить". Это означает, что:

1. Всеми авторскими правами на программу эксклюзивно обладает автор программы.

2. Вы можете использовать эту программу или ее демонстрационную версию в течение неограниченного периода времени. (Демонстрационная версия ограничена функционально)

3. Тип лицензии.

Одна лицензия на пользователя дает право использовать программу на одном компьютере.

Чтобы использовать программу на нескольких компьютерах, вы должны приобрести

специальную лицензию, поэволяющую это делать.

После регистрации пользователю предоставляется неэксклюзивная лицензия на использование RadioBOSS в любых легальных целях на количестве компьютеров, соответствующем купленной лицензии. Зарегистрированная копия RadioBoss не может быть сдана в аренду или дана напрокат, но может быть передана в полном комплекте, если получающее лицо согласно с данной лицензией.

4. Демонстрационная версия RadioBoss может распространяться свободно (кроме случаев, оговоренных ниже) лишь в том виде, в котором она поставляется, т.е. без всяких изменений комплекта поставки.

1) Запрещается распространять RadioBOSS в комплекте других программных пакетов без письменного разрешения владельца авторских прав.

5. Чтобы зарегистрироваться, вы должны купить программу.

См. подробности в файле на сайте прораммы.

6. ПРОГРАММА РАСПРОСТРАНЯЕТСЯ ПО ПРИНЦИПУ "КАК ЕСТЬ". ПРИ ЭТОМ НЕ ПРЕДУСМАТРИВАЕТСЯ НИКАКИХ ГАРАНТИЙ, ЯВНЫХ ИЛИ ПОДРАЗУМЕВАЕМЫХ. ВЫ ИСПОЛЬЗУЕТЕ ЕЁ НА СВОЙ СОБСТВЕННЫЙ РИСК. НИ АВТОР, НИ ЕГО УПОЛНОМОЧЕННЫЕ АГЕНТЫ НЕ НЕСУТ ОТВЕТСТВЕННОСТИ ЗА ПОТЕРИ ДАННЫХ, ПОВРЕЖДЕНИЯ, ПОТЕРИ ПРИБЫЛИ ИЛИ ЛЮБЫЕ ДРУГИЕ ВИДЫ ПОТЕРЬ, СВЯЗАННЫЕ С ИСПОЛЬЗОВАНИЕМ (ПРАВИЛЬНЫМ ИЛИ НЕПРАВИЛЬНЫМ) ЭТОЙ ПРОГРАММЫ.

7. Вы не можете использовать, копировать, эмулировать, клонировать, сдавать в аренду, давать напрокат, продавать, изменять, декомпилировать, дизассемблировать, передавать лицензированную программу или ее часть иначе, чем это описано в данной лицензии. Любое подобное неавторизованное использование приводит к немедленному и автоматическому прекращению действия этой лицензии и может повлечь за собой уголовное и/или гражданское преследование.

8. Установка и использование программы свидетельствует о вашем согласии с условиями данной лицензии.

10. Если вы не согласны с условиями данной лицензии, то должны удалить файлы программы со своих устройств хранения информации и отказаться от дальнейшего использования программы.


Контакты

 Top Previous

Если у вас есть вопросы по использованию программы, пожелания по улучшению или вы нашли ошибку, просьба написать письмо в нашу службу поддержки: http://www.radioboss.ru/rus/support.htm или на форум: http://www.radioboss.ru/forum_ru/

Последняя версия программы может быть загружена с сайта http://www.radioboss.ru